New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Away mode temperature fix for generic thermostat #17641

Merged
merged 6 commits into from Oct 23, 2018

Conversation

@estevez-dev
Contributor

estevez-dev commented Oct 20, 2018

Description:

Away mode temperature issue fix for generic_thermostat

Related issue (if applicable): fixes #17433

Example entry for configuration.yaml (if applicable):

climate:
  - platform: generic_thermostat
    name: Child room heater
    heater: switch.40000500dc4f22ccb55e
    target_sensor: sensor.unknown_lumisensor_ht_0222819a_1_temperature
    min_temp: 10
    max_temp: 25
    ac_mode: false
    target_temp: 22
    cold_tolerance: 0.2
    hot_tolerance: 0
    initial_operation_mode: "off"
    away_temp: 10

Checklist:

  • The code change is tested and works locally.
  • Local tests pass with tox. Your PR cannot be merged unless tests pass

If the code does not interact with devices:

  • Tests have been added to verify that the new code works.
Resolves /#17433
Away mode temperature issue fix for generic_thermostat
@homeassistant

This comment has been minimized.

homeassistant commented Oct 20, 2018

Hi @estevez-dev,

It seems you haven't yet signed a CLA. Please do so here.

Once you do that we will be able to review and accept this pull request.

Thanks!

@homeassistant homeassistant added cla-signed and removed cla-needed labels Oct 20, 2018

@estevez-dev estevez-dev changed the title from Resolves /home-assistant/home-assistant#17433 to Away mode temperature fix for generic thermostat Oct 20, 2018

@Danielhiversen

This comment has been minimized.

Member

Danielhiversen commented Oct 20, 2018

Could you add a test for this?

@estevez-dev

This comment has been minimized.

Contributor

estevez-dev commented Oct 20, 2018

Could you add a test for this?

Unfortunately I am complete zero in python. It would be very nice if someone more experienced will help me with it.

Test for repeat away_mode set
Test for fix of generic thermostat issue when away_mode was set several times in a row.
@estevez-dev

This comment has been minimized.

Contributor

estevez-dev commented Oct 22, 2018

Ok, I've added a test for setting away_mode twice. @Danielhiversen please let me know is it acceptable.

@Danielhiversen

Thanks.
Just two small details

@estevez-dev

This comment has been minimized.

Contributor

estevez-dev commented Oct 22, 2018

Done

@Danielhiversen

This comment has been minimized.

Member

Danielhiversen commented Oct 22, 2018

Looks good. Github has some issues, so the tests are not running.
Guess it soon will be fixed.

@Danielhiversen Danielhiversen merged commit 324587b into home-assistant:dev Oct 23, 2018

4 checks passed

Hound No violations found. Woof!
cla-bot Everyone involved has signed the CLA
continuous-integration/travis-ci/pr The Travis CI build passed
Details
coverage/coveralls Coverage decreased (-0.01%) to 93.592%
Details

@wafflebot wafflebot bot removed the in progress label Oct 23, 2018

@Danielhiversen

This comment has been minimized.

Member

Danielhiversen commented Oct 23, 2018

:thanks

@balloob balloob referenced this pull request Nov 9, 2018

Merged

0.82 #18335

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment