New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add additional Z-Wave Bulbs to ZW098 Workaround #19480

Merged
merged 2 commits into from Dec 22, 2018

Conversation

Projects
None yet
5 participants
@loe
Copy link
Contributor

loe commented Dec 20, 2018

Description:

Add a few more multi-led bulbs to the workaround. The long-term fix here is to probably refactor rgbw and rgb+w+w lights into separate things.
Related issue (if applicable): fixes #18767

Checklist:

  • The code change is tested and works locally.
  • Local tests pass with tox. Your PR cannot be merged unless tests pass
  • There is no commented out code in this PR.

Color temperature slider shows up for my new Aeotec ZWA003 Bulb, clicking on the "left" half gets me the cool white LED, and the "right" half gets me the warm white LED.

screen shot 2018-12-19 at 9 43 00 pm

@loe loe requested a review from home-assistant/z-wave as a code owner Dec 20, 2018

@wafflebot wafflebot bot added the in progress label Dec 20, 2018

@loe

This comment has been minimized.

Copy link
Contributor

loe commented Dec 20, 2018

It looks like travis is failing on a completely unrelated test (TestStatisticsSensor.test_initialize_from_database_with_maxage) - what is policy on fixing?

@cgarwood
Copy link
Member

cgarwood left a comment

LGTM

@cgarwood cgarwood merged commit 43e1748 into home-assistant:dev Dec 22, 2018

5 checks passed

Hound No violations found. Woof!
WIP ready for review
Details
cla-bot Everyone involved has signed the CLA
continuous-integration/travis-ci/pr The Travis CI build passed
Details
coverage/coveralls Coverage increased (+0.0003%) to 93.044%
Details

@wafflebot wafflebot bot removed the in progress label Dec 22, 2018

dshokouhi added a commit to dshokouhi/home-assistant that referenced this pull request Dec 25, 2018

@balloob balloob referenced this pull request Jan 10, 2019

Merged

0.85.0 #19897

@03397

This comment has been minimized.

Copy link

03397 commented Jan 12, 2019

I have 0.85.0 and this does not work for Aeotec ZWA001 bulb.
The slide bar is there but the light does not change.

@MartinHjelmare

This comment has been minimized.

Copy link
Member

MartinHjelmare commented Jan 12, 2019

Please open an issue if you suspect a bug. If you need help please use our help channels:
https://home-assistant.io/help/#communication-channels

Merged PRs should not be used for support or bug reports. Thanks!

@home-assistant home-assistant locked as resolved and limited conversation to collaborators Jan 12, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.