Skip to content
Permalink
Browse files

Update tests to petastorm==0.8.2 to fix pandas==1.0.0 compatibility (#…

…1702)

Signed-off-by: fardin abdi <fardin@uber.com>
  • Loading branch information
abditag2 committed Feb 4, 2020
1 parent 6c80085 commit 23d903d916cba20b2f16dcb74701a184bea3e69e
Showing with 3 additions and 3 deletions.
  1. +1 −1 Dockerfile.test.cpu
  2. +1 −1 Dockerfile.test.gpu
  3. +1 −1 setup.py
@@ -97,7 +97,7 @@ RUN pip install ${TENSORFLOW_PACKAGE}

# Install Keras.
# Pin scipy<1.4.0: https://github.com/scipy/scipy/issues/11237
RUN pip install ${KERAS_PACKAGE} h5py "scipy<1.4.0" pandas==0.24.2
RUN pip install ${KERAS_PACKAGE} h5py "scipy<1.4.0" pandas
RUN mkdir -p ~/.keras
RUN python -c "from keras.datasets import mnist; mnist.load_data()"

@@ -77,7 +77,7 @@ RUN pip install ${TENSORFLOW_PACKAGE}

# Install Keras.
# Pin scipy<1.4.0: https://github.com/scipy/scipy/issues/11237
RUN pip install ${KERAS_PACKAGE} h5py "scipy<1.4.0" pandas==0.24.2
RUN pip install ${KERAS_PACKAGE} h5py "scipy<1.4.0" pandas
RUN mkdir -p ~/.keras
RUN ldconfig /usr/local/cuda/targets/x86_64-linux/lib/stubs && \
python -c "from keras.datasets import mnist; mnist.load_data()" && \
@@ -1541,7 +1541,7 @@ def build_extensions(self):
'spark': [
'h5py>=2.9',
'numpy',
'petastorm>=0.7.7',
'petastorm==0.8.2',
'pyarrow>=0.15.0', # Petastorm 0.7.7 is not compatible with < 0.15.0
'pyspark>=2.3.2'
],

0 comments on commit 23d903d

Please sign in to comment.
You can’t perform that action at this time.