Permalink
Browse files

Puts therubyracer in asset group and only install if on linux.

  • Loading branch information...
1 parent 277ed9a commit 9a01221c5527a170c09bba5d9dd5a742200011e0 @wilkie wilkie committed Feb 19, 2013
Showing with 5 additions and 1 deletion.
  1. +5 −1 Gemfile
View
@@ -11,6 +11,11 @@ group :assets do
gem 'coffee-rails', "~> 3.2.2"
gem 'uglifier', "~> 1.0.0"
gem 'jquery-ui-rails', "~> 2.0.0"
+
+ # Many Linux environments do not have a javascript environment which is
+ # required by the asset generators. However, windows and os x have one
+ # provided by the system.
+ gem "therubyracer", "~> 0.9.9" unless RUBY_PLATFORM.match(/darwin|mswin/)
end
gem "haml", "~> 3.1.4"
@@ -68,5 +73,4 @@ end
group :test do
gem "webmock", "~> 1.6.4"
- gem "therubyracer", "~> 0.9.9"
end

0 comments on commit 9a01221

Please sign in to comment.