Skip to content
Commits on Aug 20, 2014
  1. @wilkie
Commits on Aug 6, 2014
  1. @wilkie
  2. @wilkie
  3. @wilkie

    Fixes twitter updating.

    wilkie committed Aug 5, 2014
  4. @wilkie

    Updates twitter gem.

    wilkie committed Aug 5, 2014
  5. @wilkie

    Adds testing for the admin page and admin role.

    wilkie committed Aug 5, 2014
    Initial user gets admin role.
    Admin users can set admin properties.
    
    The only admin property is user account creation toggle.
Commits on Aug 5, 2014
  1. @wilkie

    Merge pull request #803 from fmendez/fix-redirect-from-http-to-https

    wilkie committed Aug 5, 2014
    Allows open-uri redirections between HTTP and HTTPS.
  2. @wilkie

    Merge pull request #761 from ninjapanzer/capybara_update_717

    wilkie committed Aug 5, 2014
    Capybara update 717
  3. @wilkie

    Merge pull request #769 from wilkie/feature/about_us_add_dtykocki_jrg…

    wilkie committed Aug 5, 2014
    …ifford_and_skattyadz
    
    Adds dtykocki, jrgifford, and skattyadz to about us page.
  4. @wilkie
  5. @wilkie
  6. @wilkie

    Adds a multiuser/singleuser switch and admin users.

    wilkie committed Aug 5, 2014
    The first user to sign-up gets the admin bit. It is currently a secret
    page "/admin". It is secret only through the fact that there is no link
    to it. The multiuser switch will not allow any new accounts.
    
    There is no way to re-assign admin or add new admins at the moment.
    
    Look at that though, that meaningless helper somebody added
    'admin_only!' is now actually meaningful. :)
  7. @wilkie

    Updates gem versions.

    wilkie committed Aug 5, 2014
    rstatus now can install its dependencies. ratom was broken due to
    hot-linking to a fork and not only that, a branch of a fork. Don't do
    that!
    
    I (wilkie) pushed ostatus 1.0.0 which also updates ratom to its newest
    version.
  8. @wilkie

    Creates admin page and model.

    wilkie committed Aug 5, 2014
Commits on Dec 29, 2013
  1. @fmendez
Commits on Oct 29, 2013
  1. @wilkie

    Merge pull request #792 from railsaholic/refactor_reset_password_action

    wilkie committed Oct 29, 2013
    Refactors Users#reset_password_create action to reduce complexity.
    
    Creates a new class PasswordService to handle password reset and password validation logic.
Commits on Oct 27, 2013
  1. @colindean

    don't test on 1.9.2 since Gemfile specifies 1.9.3

    colindean committed Oct 27, 2013
    Travis won't test on versions older than what is specified in the Gemfile.
    
    See https://travis-ci.org/hotsh/rstat.us/jobs/13116871 for more information.
  2. @hindenbug

    refactor Users#reset_password_create action to reduce complexity

    hindenbug committed Oct 27, 2013
    Extract password reset logic in PasswordService class.
Commits on Aug 30, 2013
  1. @wilkie

    Merge pull request #774 from krainboltgreene/removing-databaseyml

    wilkie committed Aug 29, 2013
    Removes generated file: database.yml
    
    We don't use the database.yml because it was generated expecting a schema based db like sqlite3 and we are using mongo.
  2. @krainboltgreene
Commits on Aug 29, 2013
  1. @wilkie
  2. @wilkie
  3. @carols10cents

    Specify ruby 1.9.3 in the Gemfile.

    carols10cents committed Aug 28, 2013
    Heroku now uses ruby 2.0.0 as the default, but we appear to have some compatibilty issues somewhere (see #772).
    
    Heroku will use the ruby specified in the Gemfile, so this should make for a more seamless deploy experience until we fix the compatibility problem(s).
Commits on Aug 4, 2013
  1. @wilkie

    Merge pull request #768 from jrgifford/updating-rails

    wilkie committed Aug 3, 2013
    Updated rails, set ratom to point to a patched git branch until it is merged.
Commits on Aug 3, 2013
  1. @jrgifford
Commits on Jul 16, 2013
  1. @wilkie

    Upgrade mongo just because.

    wilkie committed Jul 16, 2013
  2. @wilkie
Commits on Jul 12, 2013
  1. @wilkie

    Updates twitter gem.

    wilkie committed Jul 11, 2013
Commits on Jun 2, 2013
  1. @ninjapanzer
  2. @ninjapanzer

    For some reason this failed the same tests in travis but not locally.

    ninjapanzer committed Jun 2, 2013
    I also noticed that capy 2.1.0 is not compatible with 1.9.2 so rolling back to 2.0.3
  3. @ninjapanzer

    Updated to look for first match to remove abiguous errors upgrading t…

    ninjapanzer committed Jun 1, 2013
    …o capybara 2.1.0
    
    Focused within to p within the #content div
    
    Focused within for message test from acceptance/alps/message-search
  4. @ninjapanzer

    capy upgrade

    ninjapanzer committed Jun 1, 2013
Commits on May 27, 2013
  1. @carols10cents
  2. @carols10cents
  3. @carols10cents
Something went wrong with that request. Please try again.