Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

fixes cve-2013-1854, updates twitter gem so new installs work. #754

Merged
merged 1 commit into from

3 participants

@jrgifford
Collaborator

No description provided.

@steveklabnik steveklabnik merged commit c062c7f into from
@steveklabnik

Thanks!

@wilkie
Owner

My pull request #752 from 11 days ago upgraded it more. :)

@jrgifford
Collaborator

ah, so it does. :P

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
Showing with 48 additions and 42 deletions.
  1. +1 −1  Gemfile
  2. +47 −41 Gemfile.lock
View
2  Gemfile
@@ -32,7 +32,7 @@ gem "bson", "~> 1.7.0"
gem "bson_ext", "~> 1.7.0"
gem "i18n", "~> 0.6.0"
gem "tire", "~> 0.4.1"
-gem "twitter", "~> 3.5.0"
+gem "twitter", "~> 4.0.0"
gem "pony", "~> 1.3"
gem "rdiscount", "~> 1.6.8"
gem "ratom", "~> 0.7.2"
View
88 Gemfile.lock
@@ -9,7 +9,7 @@ GIT
GIT
remote: git://github.com/earbits/delayed_job_mongo_mapper.git
- revision: 50ae64ec0a80e3dc6c86b3b851a8703ba5845cb4
+ revision: 321b3c553b664350d92327708e97dc06ab2957da
specs:
delayed_job_mongo_mapper (1.0.0)
delayed_job (~> 2.1.1)
@@ -70,50 +70,50 @@ GEM
builder
arel (3.0.2)
bcrypt-ruby (3.0.1)
- bson (1.7.0)
- bson_ext (1.7.0)
- bson (~> 1.7.0)
+ bson (1.7.1)
+ bson_ext (1.7.1)
+ bson (~> 1.7.1)
builder (3.0.4)
- capybara (1.1.2)
+ capybara (1.1.4)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- childprocess (0.3.5)
- ffi (~> 1.0, >= 1.0.6)
- chunky_png (1.2.6)
+ childprocess (0.3.9)
+ ffi (~> 1.0, >= 1.0.11)
+ chunky_png (1.2.7)
coffee-rails (3.2.2)
coffee-script (>= 2.2.0)
railties (~> 3.2.0)
coffee-script (2.2.0)
coffee-script-source
execjs
- coffee-script-source (1.3.3)
+ coffee-script-source (1.6.2)
compass (0.12.2)
chunky_png (~> 1.2)
fssm (>= 0.2.7)
sass (~> 3.1)
compass-rails (1.0.3)
compass (>= 0.12.2, < 0.14)
- crack (0.3.1)
+ crack (0.3.2)
daemons (1.1.9)
database_cleaner (0.6.7)
draper (0.11.1)
activesupport (>= 2.3.10)
erubis (2.7.0)
- eventmachine (1.0.0)
- exceptional (2.0.32)
+ eventmachine (1.0.3)
+ exceptional (2.0.33)
rack
execjs (1.4.0)
multi_json (~> 1.0)
fabrication (1.2.0)
- faraday (0.8.4)
+ faraday (0.8.6)
multipart-post (~> 1.1)
- ffi (1.1.5)
- fssm (0.2.9)
- haml (3.1.7)
+ ffi (1.4.0)
+ fssm (0.2.10)
+ haml (3.1.8)
haml-rails (0.3.5)
actionpack (>= 3.1, < 4.1)
activesupport (>= 3.1, < 4.1)
@@ -122,20 +122,19 @@ GEM
hashie (1.2.0)
hashr (0.0.22)
hike (1.2.1)
- i18n (0.6.1)
+ i18n (0.6.4)
journey (1.0.4)
jquery-rails (1.0.19)
railties (~> 3.0)
thor (~> 0.14)
- jquery-ui-rails (2.0.1)
+ jquery-ui-rails (2.0.2)
jquery-rails
railties (>= 3.1.0)
json (1.7.7)
- kgio (2.7.4)
+ kgio (2.8.0)
launchy (2.0.5)
addressable (~> 2.2.6)
- libwebsocket (0.1.5)
- addressable
+ libv8 (3.11.8.13)
libxml-ruby (2.3.3)
mail (2.4.4)
i18n (>= 0.4.0)
@@ -144,27 +143,27 @@ GEM
metaclass (0.0.1)
mime-types (1.21)
minitest (4.2.0)
- mocha (0.13.2)
+ mocha (0.13.3)
metaclass (~> 0.0.1)
- mongo (1.7.0)
- bson (~> 1.7.0)
+ mongo (1.7.1)
+ bson (~> 1.7.1)
mongo_mapper (0.12.0)
activemodel (~> 3.0)
activesupport (~> 3.0)
plucky (~> 0.5.2)
- multi_json (1.5.1)
- multipart-post (1.1.5)
+ multi_json (1.7.1)
+ multipart-post (1.2.0)
mustache (0.99.4)
newrelic_rpm (3.3.5)
- nokogiri (1.5.5)
+ nokogiri (1.5.8)
oauth (0.4.7)
- omniauth (1.1.1)
+ omniauth (1.1.3)
hashie (~> 1.2)
rack
omniauth-oauth (1.0.1)
oauth
omniauth (~> 1.0)
- omniauth-twitter (0.0.13)
+ omniauth-twitter (0.0.15)
multi_json (~> 1.3)
omniauth-oauth (~> 1.0)
opub (0.0.1)
@@ -179,8 +178,8 @@ GEM
pony (1.4)
mail (> 2.0)
pygmentize (0.0.3)
- quiet_assets (1.0.1)
- railties (~> 3.1)
+ quiet_assets (1.0.2)
+ railties (>= 3.1, < 5.0)
rack (1.4.5)
rack-cache (1.2)
rack (>= 0.4)
@@ -208,25 +207,26 @@ GEM
ratom (0.7.2)
libxml-ruby (~> 2.3.2)
rdiscount (1.6.8)
- rdoc (3.12.1)
+ rdoc (3.12.2)
json (~> 1.4)
redcarpet (1.17.2)
+ ref (1.0.4)
rest-client (1.6.7)
mime-types (>= 1.16)
rsa (0.1.4)
ruby-hmac (0.4.0)
rubyzip (0.9.9)
sass (3.1.21)
- sass-rails (3.2.5)
+ sass-rails (3.2.6)
railties (~> 3.2.0)
sass (>= 3.1.10)
tilt (~> 1.3)
- selenium-webdriver (2.25.0)
+ selenium-webdriver (2.31.0)
childprocess (>= 0.2.5)
- libwebsocket (~> 0.1.3)
multi_json (~> 1.0)
rubyzip
- show_me_the_cookies (1.1.3)
+ websocket (~> 1.0.4)
+ show_me_the_cookies (1.1.4)
capybara (~> 1.0)
simple_oauth (0.1.9)
simplecov (0.4.2)
@@ -237,12 +237,15 @@ GEM
multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
- thin (1.5.0)
+ therubyracer (0.11.4)
+ libv8 (~> 3.11.8.12)
+ ref
+ thin (1.5.1)
daemons (>= 1.0.9)
eventmachine (>= 0.12.6)
rack (>= 1.0.0)
thor (0.17.0)
- tilt (1.3.3)
+ tilt (1.3.6)
tire (0.4.3)
activemodel (>= 3.0)
hashr (~> 0.0.19)
@@ -252,11 +255,11 @@ GEM
treetop (1.4.12)
polyglot
polyglot (>= 0.3.1)
- twitter (3.5.0)
+ twitter (4.0.0)
faraday (~> 0.8)
multi_json (~> 1.3)
simple_oauth (~> 0.1.6)
- tzinfo (0.3.35)
+ tzinfo (0.3.37)
uglifier (1.0.4)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
@@ -267,7 +270,9 @@ GEM
vcr (1.10.3)
webmock (1.6.4)
addressable (~> 2.2, > 2.2.5)
+ addressable (~> 2.2, > 2.2.5)
crack (>= 0.1.7)
+ websocket (1.0.7)
whenever (0.6.8)
aaronh-chronic (>= 0.3.9)
activesupport (>= 2.3.4)
@@ -321,9 +326,10 @@ DEPENDENCIES
sass-rails (~> 3.2.5)
show_me_the_cookies (~> 1.1.0)
simplecov (~> 0.4.0)
+ therubyracer (~> 0.11.3)
thin (~> 1.5.0)
tire (~> 0.4.1)
- twitter (~> 3.5.0)
+ twitter (~> 4.0.0)
tzinfo (~> 0.3.29)
uglifier (~> 1.0.0)
unicorn (~> 4.0.1)
Something went wrong with that request. Please try again.