Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for TargetRubyVersion 2.6 #1680

Closed
raspygold opened this Issue Mar 7, 2019 · 2 comments

Comments

Projects
None yet
3 participants
@raspygold
Copy link

raspygold commented Mar 7, 2019

We are trying to set Hound to target Ruby 2.6 but it looks like Hound is not compatible with 2.6 due to the version of Rubocop in use currently. Support for targeting Ruby 2.6 was added in Rubocop v0.60.0 and Hound seems to using v0.59.2.

For now we'll set the target Ruby version back to 2.5 until Hound can support 2.6.

@gylaz

This comment has been minimized.

Copy link
Member

gylaz commented Mar 7, 2019

Hound supports both Ruby 2.6 and RuboCop version 0.64.0.
You can read about setting the version here: http://help.houndci.com/configuration/linter-versioning
and check which linter versions we support here: http://help.houndci.com/configuration/supported-linters

Let me know if that helps.

@yiweig

This comment has been minimized.

Copy link

yiweig commented Mar 19, 2019

I think we also hit this? Running rubocop 0.62.0, and ran into this error after merging in this change to our .rubocop.yml: TargetRubyVersion: 2.6.

Screen Shot 2019-03-19 at 10 39 56 AM

Maybe I'm missing some configs or something, is there anything else I should check?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.