Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

v1.0

Move -lz out of the Minix special case, where it doesn't belong
and back into the general case.

v0.16

This is a retroactive tag to mark the original v0.16 sources.

jym-xensuspend-base

Enable WARNS=4 by default for usr.bin, except for:
	awk  bdes  checknr  compile_et  error  gss  hxtool  kgetcred  kinit
	klist  ldd  less  lex  locale  login  m4  man  menuc  mk_cmds
	mklocale  msgc  openssl  rpcgen  rpcinfo  sdiff  spell  ssh
	string2key  telnet  tn3270  verify_krb5_conf  xlint

OPENBSD_4_5_BASE

bump the posix reference in STANDARDS to IEEE Std 1003.1-2008, with a…
… few

updates to follow;

yamt-pf42-baseX

sync with pkgsrc changes - reorder includes and add some casts

OPENBSD_4_4_BASE

Process patterns containing $ end ^ (but not as last or first char)
using regcomp() instead of fastcomp(). ok millert@

OPENBSD_4_1_BASE

- Be explicit on command line checking, instead of relying on patterns,
  which may be NULL (e.g. -e '').
- let add_pattern() decide how to deal with empty patterns, don't do
  magic in read_patterns().

This unbreaks stuff like grep -e '', and makes grep -f <file> more
POSIX compliant. Semantics for grep -f /dev/null (or any other empty
file) may be questionable, but this case isn't specified by POSIX,
and matching nothing at all seems to be sane.

Thanks to otto@, who mentioned potential problems related to the
-x option with the first patch i sent.

ok jaredy@ (some time ago), otto@, millert@

netbsd-4-0-RC5

Changed the type of some size variables from int to size_t. Added const
qualifiers to some parameters. These changes allow WARNS to be raised to
4.
Something went wrong with that request. Please try again.