Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Final Fantasy IV: The Complete Collection (ULUS10560) - Weird flickerings and strange noises #3422

Closed
pal1000 opened this Issue Aug 26, 2013 · 5 comments

Comments

Projects
None yet
2 participants
@pal1000
Copy link
Contributor

commented Aug 26, 2013

Today, after upgrading PPSSPP to v0.9.1-150-g49d41ab, I noticed some issues:
-screen flickers repeatedly when game starts and a bit when screen restores from black state and sometimes before going into black state;
-sometimes when screen goes black or when accessing Save/Load game option a strange noise can be heard when saves list gets populated and especially when you close that list (press circle afterwards).

The flickering seams to appeared between v0.9.1-134-g554ca84 (latest known good) and v0.9.1-137-gdea972b (first known bad). Progressively became even worse (occurs in even more situations) afterward, noticed in v0.9.1-139-g3cfd89a, v0.9.1-141-g8a32dd3, v0.9.1-142-gfbfbe6d, and finally I could notice the worst state in v0.9.1-144-g95f9128. It's much better in v0.9.1-176-gfdaff2a but it still flicker like crazy when that auto-save notification screen pop-ups right at game boot.

The weird noise appeared between v0.9.1-66-g786745b (last known good) and v0.9.1-79-g5798e7d (first known bad). It became stronger since the flicker issue began.
Savedata is available here, if needed. I am currently playing Final Fantasy IV: The After Years Palom's Tale on File 4. Although I cheated, the cheat file is not needed to test and debug.

Off topic: I also made some findings regarding this issue which was never fixed and still affects even this brand new interface.

@unknownbrackets

This comment has been minimized.

Copy link
Collaborator

commented Aug 26, 2013

Most likely caused by:

2d806b4

Or by the setting being enabled by default. The noise thing is most likely caused by this:

507050e

-[Unknown]

@unknownbrackets

This comment has been minimized.

Copy link
Collaborator

commented Aug 27, 2013

Okay, so the flicker is only with buffered rendering off. Should be fixable.

The other one, I hear it too... strange.

-[Unknown]

@pal1000

This comment has been minimized.

Copy link
Contributor Author

commented Aug 27, 2013

Tested PPSSPP v0.9.1-200-g87c1dc3 and both issues seams fixed. There are still one lone flicker on that auto-save notification shows up at boot and some flickers when quickly moving on world map.

@unknownbrackets

This comment has been minimized.

Copy link
Collaborator

commented Aug 27, 2013

Those existed before, though. Non-buffered rendering will never be perfect...

-[Unknown]

@pal1000

This comment has been minimized.

Copy link
Contributor Author

commented Aug 28, 2013

Yes @unknownbrackets, that's what I wanted to point out to begin with.

@pal1000 pal1000 closed this Aug 28, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.