Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dupeGuru PPA is outdated #484

Open
seb-1204 opened this Issue Feb 12, 2018 · 8 comments

Comments

Projects
None yet
5 participants
@seb-1204
Copy link

seb-1204 commented Feb 12, 2018

Hello,
I'm not sure if this is the right place to raise this but are there any plans to provide updated versions to the Ubuntu PPA ?

The last build is from 2017-08-25, current Ubuntu release is 17.10 (Artful Aardvark) rleased in October 2017.

I thought the building of the DEB files for the PPA is an automated process. So could this be checked and fixed? Unfortunately I'm lacking the skills to be more helpful.

@hsoft

This comment has been minimized.

Copy link
Owner

hsoft commented Feb 15, 2018

Yeah, I haven't figured out how to automate the process. I have to update it manually.

@hsoft

This comment has been minimized.

Copy link
Owner

hsoft commented Feb 15, 2018

Please note that this project is unmaintained. I'm not going to continue updating that PPA. If someone want to maintain a PPA somewhere, I'll be happy to point to it on the website.

@Cebtenzzre

This comment has been minimized.

Copy link

Cebtenzzre commented May 12, 2018

Someone (at this point probably @arsenetar) should set up a build server to be configured to update the PPA, or at least remember to update the PPA when (if?, lol) new releases are built. I'm considering (co-)maintaining the Arch AUR package(s), which due to the nature of Arch can be capable of building itself.

@arsenetar

This comment has been minimized.

Copy link
Collaborator

arsenetar commented May 12, 2018

I am planning on setting up the Linux packaging to be built with a build server. I have not setup a PPA before so I have a bit to figure out.

@DJCrashdummy

This comment has been minimized.

Copy link
Contributor

DJCrashdummy commented May 12, 2018

just a little question:
is it possible to update the "official PPA" or will it be necessary to change to a new one?

@hsoft

This comment has been minimized.

Copy link
Owner

hsoft commented May 12, 2018

The PPA is currently in my personal launchpad namespace. a new PPA will have to be created and will become the official one.

@DJCrashdummy

This comment has been minimized.

Copy link
Contributor

DJCrashdummy commented May 13, 2018

hmm, i never created a PPA: is there any possibility to notify the people using the current PPA to switch to the new one?
...maybe as a last resort a "fake-update" with a (somehow recurring) notification?

@Cebtenzzre

This comment has been minimized.

Copy link

Cebtenzzre commented May 13, 2018

@DJCrashdummy Looks like lxc/lxd#4176 represents what's been done in the past: Send an update out that displays a warning when starting the program. After a few months, remove the old PPA entirely. Errors about missing PPAs and months of warnings should be enough to get users to switch.

@arsenetar arsenetar added the Linux label May 22, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.