Skip to content
This repository has been archived by the owner. It is now read-only.
master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
src
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Node Security plugin v0.4.0

Gitter Build Status

Donate

Version Downloads Downloads last month

Introduction

IntelliJ Node Security plugin that indicates which Node packages in your project are vulnerable. Plugin checks your dependencies against nodesecurity.io service.

It supports following JetBrains IDEs:

  • Android Studio
  • AppCode
  • CLion
  • IntelliJ IDEA
  • PhpStorm
  • PyCharm
  • RubyMine
  • WebStorm
  • DataGrip

Features

  • Highlight vulnerable dependencies in package.json file.
  • Verify package.json files when project is opened
  • package-lock.json and yarn.lock support
  • deep check of vulnerabilities

Highlight vulnerable dependencies

Installation

  • Using IDE built-in plugin system:
    • Preferences > Plugins > Browse repositories... > Search for "Node security" > Install Plugin
  • Manually:
    • Download the latest release and install it manually using Preferences > Plugins > Install plugin from disk...

Restart IDE.

Changelog

v0.4.0 (2018-03-05)

Full Changelog

Implemented enhancements:

  • package-lock.json and yarn.lock support
  • deep check of vulnerabilities
  • performance optimizations
  • semver test fix

Fixed bugs

  • Won't accept electron beta version (#6)

Full Changelog History

Contribution

Check CONTRIBUTING.md file.

Developed By

@hsz Jakub Chrzanowski

Contributors

  • none

License

Copyright (c) 2018 hsz Jakub Chrzanowski. See the LICENSE file for license rights and limitations (MIT).

About

IntelliJ Node Security plugin that indicates which Node packages in your project are vulnerable.

Resources

License

Code of conduct

Stars

Watchers

Forks

Packages

No packages published