Can not run this app with ruby 1.9.3 #5

Closed
KanybekMomukeyev opened this Issue May 27, 2012 · 12 comments

4 participants

@KanybekMomukeyev

Sorry, i m new to Ruby on Rails.
This error message:

An error occured while installing linecache (0.46), and Bundler cannot continue.
Make sure that gem install linecache -v '0.46' succeeds before bundling.

@huerlisi
Owner

Bookyt is currently not compatible with Ruby 1.9.3. We're using Ruby 1.8.7, but as we get this request on all channels, we'll consider making it compatible with Ruyb 1.9.3 as soon as time permits.

Any help in "porting" is very much appreciated.

@raskhadafi
Collaborator

This specific error is caused by the ruby-debug gem which uses linecache.

@KanybekMomukeyev

So what shoul i do?

@raskhadafi
Collaborator

@KanybekMomukeyev try the ruby-1.9.3 branch I just started it so at the moment it is work in progress.
Do you want to help?

@KanybekMomukeyev

Ok, big thanks, i will try it now.
IF there appear any question, i will write here.
Problem with mysql:
"Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)"

@KanybekMomukeyev

Ok, after install mysql, and done with settings,
i have this error:
/lib/active_support/dependencies.rb:251:in `block in require': iconv will be deprecated in the future, use String#encode instead

@huerlisi
Owner

@raskhadafi cool to see you working on this!

Did you get Bookyt running using 1.9.3? What issues do you know that still need some work?

Would be great if you could create a pull request if you think things should work. I'll give it some hard testing then;-)

@raskhadafi
Collaborator

@huerlisi I think I owe you a little status report (I added some notes in the Changelog). ;-)
A the moment the ruby-1.9.3 branch can start the app with 1.9.3.
Another major change is I started to use guard cause I found out it's much easier to setup and use.

@raskhadafi raskhadafi was assigned Jun 2, 2012
@huerlisi
Owner

@raskhadafi Very cool, thanks! I'll give it a try and will integrate in the next few days. Been on holiday for 2 weeks. Took it seriously and read close to no mails;-)

@kitsane
Collaborator

Integrated changes from @raskhadafi. It should work now with ruby 1.87 and ruby 1.9.3.

@kitsane kitsane closed this Jun 20, 2012
@raskhadafi
Collaborator

Thanks guys! I hope everything works still! ;-)

@huerlisi
Owner

Thank YOU!

@Kitsane fixed some small, remaining issues, an I fixed a small problem only happening on deployment (2c9813c) a few minutes ago:-)

Happy weekend!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment