Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Twitter Stream agent only follows first filter on first agent #406

Closed
kazazes opened this Issue Jul 20, 2014 · 7 comments

Comments

Projects
None yet
4 participants

kazazes commented Jul 20, 2014

I can't seem to get multiple twitter stream agents to run. So far, I can only get it to generate events for the FIRST filter of the FIRST agent. I'm not sure what is meant by "If you provide an array instead of a filter, the first entry will be considered primary and any additional values will be treated as aliases." What is meant by aliases? Are they not primary filters?

If I set the first one to "testphrase101" and the second to "testphrase102", I only generate events on the first time. I can't get a second agent to generate events at all.

Owner

cantino commented Jul 20, 2014

Could you paste in the JSON Agent configuration you're using?

kazazes commented Jul 20, 2014

{
  "filters": [
    "kazazes",
    "sibyl vision"
  ],
  "expected_update_period_in_days": "4",
  "generate": "events"
}

kazazes commented Jul 20, 2014

"Kazazes" will get caught, but "sibyl vision" will not. Adding an entirely new streaming agent doesn't change anything.

Owner

cantino commented Jul 20, 2014

That's very odd. Could you try something more common for the second one, like "nasa mars" or something?

@alias1 alias1 added the bug label Jul 23, 2014

Owner

cantino commented Jul 29, 2014

Hey @kazazes, did you get a chance to try a more common second example case?

Contributor

virtadpt commented Aug 2, 2014

I've been trying to reproduce this, but haven't been able to:

  "filters": [
    "shooting silver spring",
    "shooting pittsburgh",
    "shooting fort hood",
    "shooting oakland",
    "drug overdose ong's hat"
  ],

In the past several days, a couple of those filters have matched from that agent successfully. Could you please post a gist of the agent you're having trouble with? Maybe the bug is outside of the filters[] list.

Owner

cantino commented Feb 14, 2016

I'm going to close this issue. Please reopen if you want to discuss further!

@cantino cantino closed this Feb 14, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment