Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Forced to reinstall extension #99

Closed
ghost opened this issue Jan 23, 2021 · 4 comments
Closed

Forced to reinstall extension #99

ghost opened this issue Jan 23, 2021 · 4 comments
Assignees
Labels
bug Something isn't working

Comments

@ghost
Copy link

ghost commented Jan 23, 2021

Over the past couple days: I've twice needed to remove and re-install the extension for search to work properly. Browser is: FF78.6.1esr (64-bit).

@Folyd
Copy link
Member

Folyd commented Jan 24, 2021

 Thanks for the feedback. Could you please give me more detail about work improperly? Can't use rs to search? Or search something but get nothing result?

@ghost
Copy link
Author

ghost commented Jan 24, 2021

Yeah, thanks for getting back. I can enter rs in the address bar and it shows
a single line item but no related results and pressing enter for whatever the
input merely redirects to the browsers search provider. I restarted my system
today and am again required to reinstall the extension.

@tdonovan4
Copy link

I ran into the same issue using Firefox 84.0.2. This is the error message I got:

Uncaught (in promise) TypeError: rawSearchIndex[crate] is undefined
    buildIndex moz-extension://21a652d7-2f59-4b03-a403-777fc59763ac/search/docs/base.js:82
    DocSearch moz-extension://21a652d7-2f59-4b03-a403-777fc59763ac/search/docs/base.js:43
    NightlySearch moz-extension://21a652d7-2f59-4b03-a403-777fc59763ac/search/docs/std.js:13
    <anonymous> moz-extension://21a652d7-2f59-4b03-a403-777fc59763ac/main.js:34
    async* moz-extension://21a652d7-2f59-4b03-a403-777fc59763ac/main.js:364
base.js:82:17

I did some digging and found out that the culprit was the key index-std-nightly in the extension
storage whose value was set to {proc_macro: undefined, std: undefined, test: undefined}.

I was able to fix the issue by deleting the key and updating the index. However, it came back
later and I had to do the manipulation again.

@Folyd Folyd added the bug Something isn't working label Jan 26, 2021
@Folyd Folyd self-assigned this Jan 26, 2021
@Folyd
Copy link
Member

Folyd commented Jan 26, 2021

Thanks! This is a bug, I'll fix this ASAP.

@Folyd Folyd closed this as completed in 0230678 Jan 28, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something isn't working
Projects
None yet
Development

No branches or pull requests

2 participants