Skip to content

Upgrade jaxen to 1.1.4 in jdom 1.1.x #103

Open
aheritier opened this Issue Dec 19, 2012 · 2 comments

2 participants

@aheritier

Hi,

jaxen 1.1.3 artifacts deployed in maven central has some wrong dependencies defined in its pom (some maven-plugins - cobertura, findbugs - with an erroneous type "plugin"). Because of that using jdom 1.1.3 by default with maven doesn't work. Either you could provide in central a 1.1.4 with an exclusion of these wrong dependencies or upgrade your jaxen version, the 1.1.4 fixed the issue.
This is the current fix that a maven user is required to do to use jdom 1.1.3.

Cheers,

@rolfl
Collaborator
rolfl commented Dec 20, 2012

Hi Arnaud

There are currently no bugs open against 1.1.x versions of JDOM. I understand that this is a usability problem, but I am not inclined to create a whole new version of JDOM unless there is an issue with the actual JDOM code.

I will leave this issue open, and if/when an 1.1.x issue is identified (and a migration path to 2.x is not an option), then this (or whatever appropriate) fix can be applied.

Rolf

@aheritier

Hi Rolf,

I agree. The goal of my issue was at least to have it referenced here if someone else meet the problem.

Arnaud

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.