Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

m4_esyscmd_s doesnt seem to be portable across different systems

Signed-off-by: Mikko Koppanen <mikko.koppanen@gmail.com>
  • Loading branch information...
commit 908b39bf8309044913a34c632cd432958dcf6960 1 parent c8e5be8
@testraymond testraymond authored sustrik committed
Showing with 2 additions and 2 deletions.
  1. +1 −1  configure.in
  2. +1 −1  version.sh
View
2  configure.in
@@ -6,7 +6,7 @@ AC_PREREQ(2.61)
# the version.sh script. Hence, it should be updated there.
# The version in git should reflect the *next* version planned.
#
-AC_INIT([zeromq],[m4_esyscmd_s([./version.sh])],[zeromq-dev@lists.zeromq.org])
+AC_INIT([zeromq],[m4_esyscmd([./version.sh])],[zeromq-dev@lists.zeromq.org])
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(config)
View
2  version.sh
@@ -17,5 +17,5 @@ fi
MAJOR=`echo $MAJOR | awk '{ print $3 }'`
MINOR=`echo $MINOR | awk '{ print $3 }'`
PATCH=`echo $PATCH | awk '{ print $3 }'`
-echo $MAJOR.$MINOR.$PATCH
+echo $MAJOR.$MINOR.$PATCH | tr -d '\n'
Please sign in to comment.
Something went wrong with that request. Please try again.