Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

[COOK-2435] Fix foodcritic errors. #43

Merged
merged 1 commit into from

2 participants

@juliandunn

FC002: Avoid string interpolation where not required: ./recipes/yum_pgdg_postgresql.rb:50
FC002: Avoid string interpolation where not required: ./recipes/yum_pgdg_postgresql.rb:56
FC007: Ensure recipe dependencies are reflected in cookbook metadata: ./recipes/ppa_pitti_postgresql.rb:1
FC007: Ensure recipe dependencies are reflected in cookbook metadata: ./recipes/ruby.rb:30

I left this one alone:

FC024: Consider adding platform equivalents: ./attributes/default.rb:90

because I'm pretty sure Amazon Linux does things different and that's why there's a separate clause for it.

Julian C. Dunn [COOK-2435] Fix foodcritic errors.
FC002: Avoid string interpolation where not required: ./recipes/yum_pgdg_postgresql.rb:50
FC002: Avoid string interpolation where not required: ./recipes/yum_pgdg_postgresql.rb:56
FC007: Ensure recipe dependencies are reflected in cookbook metadata: ./recipes/ppa_pitti_postgresql.rb:1
FC007: Ensure recipe dependencies are reflected in cookbook metadata: ./recipes/ruby.rb:30
2b9fab9
@jtimberman jtimberman merged commit 313b08f into from
@juliandunn juliandunn deleted the branch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Feb 19, 2013
  1. [COOK-2435] Fix foodcritic errors.

    Julian C. Dunn authored
    FC002: Avoid string interpolation where not required: ./recipes/yum_pgdg_postgresql.rb:50
    FC002: Avoid string interpolation where not required: ./recipes/yum_pgdg_postgresql.rb:56
    FC007: Ensure recipe dependencies are reflected in cookbook metadata: ./recipes/ppa_pitti_postgresql.rb:1
    FC007: Ensure recipe dependencies are reflected in cookbook metadata: ./recipes/ruby.rb:30
This page is out of date. Refresh to see the latest.
Showing with 4 additions and 2 deletions.
  1. +2 −0  metadata.rb
  2. +2 −2 recipes/yum_pgdg_postgresql.rb
View
2  metadata.rb
@@ -20,4 +20,6 @@
supports el, ">= 6.0"
end
+depends "apt"
+depends "build-essential"
depends "openssl"
View
4 recipes/yum_pgdg_postgresql.rb
@@ -47,13 +47,13 @@
# Download the PGDG repository RPM as a local file
remote_file "#{Chef::Config[:file_cache_path]}/#{repo_rpm_filename}" do
- source "#{repo_rpm_url}"
+ source repo_rpm_url
mode "0644"
end
# Install the PGDG repository RPM from the local file
# E.g., /etc/yum.repos.d/pgdg-91-centos.repo
-package "#{repo_rpm_package}" do
+package repo_rpm_package do
provider Chef::Provider::Package::Rpm
source "#{Chef::Config[:file_cache_path]}/#{repo_rpm_filename}"
action :install
Something went wrong with that request. Please try again.