Fatal Error: Declaration of Hybrid_Storage::config() must be compatible with that of Hybrid_Storage_Interface::config() #413

Closed
StorytellerCZ opened this Issue Mar 11, 2015 · 1 comment

Projects

None yet

2 participants

@StorytellerCZ
Contributor

Going of https://www.drupal.org/node/2332631

Fatal error: Declaration of Hybrid_Storage::config() must be compatible with that of Hybrid_Storage_Interface::config() in /Hybrid/Storage.php on line 13`
@StorytellerCZ StorytellerCZ added the 2.x label Mar 11, 2015
@StorytellerCZ StorytellerCZ added this to the 2.x milestone Mar 11, 2015
@miled
Contributor
miled commented Mar 12, 2015

I think this happen with php <=5.2.

https://github.com/hybridauth/hybridauth/blob/master/hybridauth/Hybrid/StorageInterface.php#L13

$value needs to be eq null.

@miled miled closed this in 627a5b0 Mar 12, 2015
@StorytellerCZ StorytellerCZ added a commit that referenced this issue Mar 12, 2015
@StorytellerCZ StorytellerCZ fix #413
Missed one
61b1932
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment