Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tree: e35500a7e4
Fetching contributors…

Cannot retrieve contributors at this time

67 lines (53 sloc) 2.254 kb
===
title: Installation
subtitle: PIPing hot hyde
created: 2011-01-26 23:17:44
toc: getting started
inedx: 2
===
§§ blurb
Installing hyde is as simple as running the following command:
~~~sh~~~
pip install hyde
~~~~~~~~
§§ /blurb
However, based on your choice and use of plugins you may need to install
additional packages. The requirements for each plugin is outlined in the
corresponding [plugin documentation][plugins].
## Dependencies
While your mileage may vary, we consider the following to be essential for
generating a static website with hyde. These are a part of the requirements
file and the above command will download and install all of them as part
of hyde.
It is also recommended that you use [virtualenv][] to separate the hyde
environment from other python projects. Note that installing hyde using
pip would install all of the below. However, if you'd like finer grained
control over the packages, you can install these individually:
1. `argparse`: argparse is required if you are on python 2.6.
2. `commando`: commando is a wrapper on top of argparse to give better syntax
and support for multi-command applications.
3. `Jinja2`: While hyde will support many more template languages in the
future, currently, Jinja2 is wholly supported and recommended.
4. `Markdown`: While there are plans to add support for other markups
(textile, restructured text, asciidoc etc..,), markdown is the one thats
currently completely supported.
5. `Pyyaml`: Much of hyde's [configuration][] is done using yaml.
6. `pygments`: For syntax coloring.
7. `Typogrify`: Typogrify automatically fixes and enhances the typographical
accuracy of your content. While this is not a technical requirement for
hyde, it is absolutely essential to create good looking content.
The following commands can be used to install the dependencies for hyde
individually:
~~~sh~~~
pip install argparse
pip install commando
pip install jinja2
pip install markdown
pip install pyyaml
pip install pygments
pip install smartypants
pip install -e git://github.com/hyde/typogrify#egg=typogrify
~~~~~~~~
[plugins]: [[plugins]]
[virtualenv]: http://mathematism.com/2009/07/30/presentation-pip-and-virtualenv/
[configuration]: [[config]]
Jump to Line
Something went wrong with that request. Please try again.