Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Docs.hylang.org is broken #1806

Closed
paultag opened this issue Aug 4, 2019 · 15 comments

Comments

@paultag
Copy link
Member

commented Aug 4, 2019

Anyone have an idea why? I'll fix the DNS!

@paultag paultag self-assigned this Aug 4, 2019

@Kodiologist

This comment has been minimized.

Copy link
Member

commented Aug 4, 2019

Aw dang, I noticed that a few days ago and assumed it was just a temporary blip. I have no idea what happened.

@paultag

This comment has been minimized.

Copy link
Member Author

commented Aug 4, 2019

Yeah me either. I'll try and dig in later

@rcarmo

This comment has been minimized.

Copy link

commented Aug 5, 2019

Yeah, it would be handy to be able to check the docs now and then... Maybe generating a PDF is in order? :)

@Kodiologist

This comment has been minimized.

Copy link
Member

commented Aug 5, 2019

This is just a DNS issue. You can still see the website at http://hy.readthedocs.org.

@rcarmo

This comment has been minimized.

Copy link

commented Aug 6, 2019

Search doesn't work there, because it links back to the missing domain.

@paultag

This comment has been minimized.

Copy link
Member Author

commented Aug 6, 2019

I switched the CNAME to readthedocs.io rather than readthedocs.org (maybe stale config?) and also enabled HTTPS while I was in there (thanks @tianon for the docs tip) - let's see what that does

@tianon

This comment has been minimized.

Copy link
Contributor

commented Aug 6, 2019

it's working!

@paultag

This comment has been minimized.

Copy link
Member Author

commented Aug 6, 2019

I've got a bit of DNS TTL in front of me, I'm going to have to wait, if someone else feels like they were able to validate my work, feel free to close the ticket!

Really weird bug.

@refi64

This comment has been minimized.

Copy link
Contributor

commented Aug 6, 2019

Looks like it's up flying hy now!

@refi64 refi64 closed this Aug 6, 2019

@paultag

This comment has been minimized.

Copy link
Member Author

commented Aug 6, 2019

Thanks for validating! Sorry about that - I really don't understand the problem, much less why the solution worked.

My assumption was it was set to .org because that's what you were supposed to do when we set it up, and eventually rtd flipped over to their .io records, and something about that caused a cloudflare hiccup eventually.

If anyone wants to do more of a post-mortum I'd love to make sure that I didn't fix this by mistake :)

@tianon

This comment has been minimized.

Copy link
Contributor

commented Aug 7, 2019

FWIW, .io is what https://docs.readthedocs.io/en/latest/custom_domains.html points to, so it does appear to be the correct thing to do (and IMO that points strongly to it being related and not accidentally fixed)

@paultag

This comment has been minimized.

Copy link
Member Author

commented Aug 7, 2019

@tianon Relieving! I still have no idea how I got .org to begin with unless it changed over time and we got left behind

@tianon

This comment has been minimized.

Copy link
Contributor

commented Aug 7, 2019

Took a bit of digging, but readthedocs/readthedocs.org@ac6e879 seems relevant 😅

@paultag

This comment has been minimized.

Copy link
Member Author

commented Aug 7, 2019

@tianon

This comment has been minimized.

Copy link
Contributor

commented Aug 7, 2019

I was hoping to find more details but even readthedocs/readthedocs.org#2209 is scarce 😕

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.