Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Caliper zookeeper setup problem #572

Closed
TopJohn opened this issue Sep 4, 2019 · 1 comment
Labels

Comments

@TopJohn
Copy link

@TopJohn TopJohn commented Sep 4, 2019

I use caliper to test hyperledger fabric, and try to use zookeeper type to do distributed test.But i got a problem.

Context

firstly, i use command:
caliper zooservice start
1
it looks like good.
to run a local docker zookeeper nodes.
And then,run command:
caliper zooclient start --caliper-zooaddress 127.0.0.1:2181 --caliper-workspace ~/Documents/caliper --caliper-networkconfig packages/caliper-samples/network/fabric-v1.4/2org1peergoleveldb/fabric-go-tls.yaml
2
no more log output, it's strange.

and the zookeeper's logs output:
3

when i run benchmark test , caliper told me no nodes register in zookeeper.so ....

Expected Behavior

Actual Behavior

Possible Fix

Steps to Reproduce

Existing issues

Context

Your Environment

  • Version used: v0.1.0
  • Environment name and version (e.g. Chrome 39, node.js 5.4): node version:v8.16.0
  • Operating System and version (desktop or mobile): ubuntu 19 or centos 7 both have these problem
  • Link to your project:
@aklenik

This comment has been minimized.

Copy link
Contributor

@aklenik aklenik commented Sep 11, 2019

@TopJohn The zookeeper-based clients will be removed in v0.2.0 and a new solution will take its place in v0.3.0
Until then, try scaling your local clients (and resources).

@aklenik aklenik added the wontfix label Sep 11, 2019
@stale stale bot closed this Sep 18, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
2 participants
You can’t perform that action at this time.