Permalink
Browse files

Merge remote-tracking branch 'origin/feature/rc_1_6_6' into feature/r…

…c_1_6_6
  • Loading branch information...
jovfer committed Sep 19, 2018
2 parents 15fe319 + a2a5c36 commit 531a2cf71ded7ee5b7f3640dce071873c1609af5
View
@@ -1,4 +1,6 @@
# Changelog
## 1.6.6
* Fixed Android build rustflags. Now all architectures have same flags.
## 1.6.5
* Fixed `ARGON2I` constants usage to be compatible with the latest sodium.
View
@@ -941,7 +941,7 @@ def downloadPackagingUtils() {
}
def setupRust() {
sh "rustup default 1.26.0"
sh "rustup default 1.27.0"
}
def androidPublishing() {
View
@@ -535,7 +535,7 @@ def closePool(env_name, network_name, poolInst) {
}
def setupRust() {
sh "rustup default 1.26.0"
sh "rustup default 1.27.0"
}
def setupRustIOS() {
@@ -0,0 +1,23 @@
{
"name": "libindy-objc",
"version": "1.6.6",
"summary": "Summary TODO.",
"homepage": "TODO",
"license": {
"type": "Apache License 2.0",
"file": "LICENSE"
},
"authors": {
"Daniel Hardman": "daniel.hardman@evernym.com"
},
"source": {
"http": "https://repo.sovrin.org/ios/libindy/stable/indy-objc/1.6.6/libindy-objc.zip"
},
"platforms": {
"ios": "10.0"
},
"ios": {
"vendored_frameworks": "libindy-objc/Indy.framework"
},
"module_name": "Indy"
}
@@ -0,0 +1,23 @@
{
"name": "libindy",
"version": "1.6.6",
"summary": "Summary TODO.",
"description": "Description TODO.",
"homepage": "TODO",
"license": {
"type": "Apache License 2.0",
"file": "LICENSE"
},
"authors": {
"Daniel Hardman": "daniel.hardman@evernym.com"
},
"platforms": {
"ios": "10.0"
},
"source": {
"http": "https://repo.sovrin.org/ios/libindy/stable/libindy-core/1.6.6/libindy.tar.gz"
},
"source_files": "*.h",
"vendored_libraries": "*.a",
"requires_arc": false
}
View

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
View
@@ -1,6 +1,6 @@
[package]
name = "indy-cli"
version = "1.6.5"
version = "1.6.6"
authors = ["Vyacheslav Gudkov <vyacheslav.gudkov@dsr-company.com>"]
[features]
View
@@ -1,4 +1,4 @@
indy-cli (1.6.5) unstable; urgency=medium
indy-cli (1.6.6) unstable; urgency=medium
[ Hyperledger ]
View

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
View
@@ -1,6 +1,6 @@
[package]
name = "indy"
version = "1.6.5"
version = "1.6.6"
authors = [
"Sergej Pupykin <sergej.pupykin@dsr-company.com>",
"Vyacheslav Gudkov <vyacheslav.gudkov@dsr-company.com>",
View
@@ -148,14 +148,9 @@ build(){
pushd ${WORKDIR}
rm -rf target/${TRIPLET}
cargo clean
if [ "${ABSOLUTE_ARCH}" == "x86_64" ]; then
LD_LIBRARY_PATH=${TOOLCHAIN_DIR}/sysroot/usr/${TOOLCHAIN_SYSROOT_LIB} \
RUSTFLAGS="-C link-args=-Wl,-rpath,${TOOLCHAIN_DIR}/sysroot/usr/${TOOLCHAIN_SYSROOT_LIB} -L${TOOLCHAIN_DIR}/${ANDROID_TRIPLET}/${TOOLCHAIN_SYSROOT_LIB} -lgnustl_shared" \
cargo build --release --target=${TRIPLET}
else
RUSTFLAGS="-L${TOOLCHAIN_DIR}/${TRIPLET}/lib -lgnustl_shared" \
cargo build --release --target=${TRIPLET}
fi
LD_LIBRARY_PATH=${TOOLCHAIN_DIR}/sysroot/usr/${TOOLCHAIN_SYSROOT_LIB} \
RUSTFLAGS="-C link-args=-Wl,-rpath,${TOOLCHAIN_DIR}/sysroot/usr/${TOOLCHAIN_SYSROOT_LIB} -L${TOOLCHAIN_DIR}/${ANDROID_TRIPLET}/${TOOLCHAIN_SYSROOT_LIB} -lgnustl_shared" \
cargo build --release --target=${TRIPLET}
popd
}
@@ -39,7 +39,7 @@ RUN wget https://repos.fedorapeople.org/repos/dchen/apache-maven/epel-apache-mav
RUN sed -i s/\$releasever/6/g /etc/yum.repos.d/epel-apache-maven.repo
RUN yum install -y apache-maven
ENV RUST_ARCHIVE=rust-1.26.0-x86_64-unknown-linux-gnu.tar.gz
ENV RUST_ARCHIVE=rust-1.27.0-x86_64-unknown-linux-gnu.tar.gz
ENV RUST_DOWNLOAD_URL=https://static.rust-lang.org/dist/$RUST_ARCHIVE
RUN mkdir -p /rust
@@ -55,7 +55,7 @@ RUN apt-get install -y zip
RUN useradd -ms /bin/bash -u $uid indy
USER indy
RUN curl https://sh.rustup.rs -sSf | sh -s -- -y --default-toolchain 1.26.0
RUN curl https://sh.rustup.rs -sSf | sh -s -- -y --default-toolchain 1.27.0
ENV PATH /home/indy/.cargo/bin:$PATH
WORKDIR /home/indy
View
@@ -1,7 +1,10 @@
libindy (1.6.5) unstable; urgency=medium
libindy (1.6.6) unstable; urgency=medium
[ Hyperledger ]
* 1.6.6
* Fixed Android build rustflags. Now all architectures have same flags.
* 1.6.5
* Fixed `ARGON2I` constants usage to be compatible with the latest sodium.
* Parameter `submitter_did` set as the optional field for:
View

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
View
@@ -1,6 +1,6 @@
[package]
name = "null-payment-method"
version = "1.6.5"
version = "1.6.6"
authors = ["Nikita Khateev <nikita.khateev@dsr-corporation.com>"]
build = "build.rs"
@@ -1,4 +1,4 @@
libnullpay (1.6.5) unstable; urgency=medium
libnullpay (1.6.6) unstable; urgency=medium
[ Hyperledger ]
* Initial release
View
@@ -5,7 +5,7 @@
<groupId>org.hyperledger</groupId>
<artifactId>indy</artifactId>
<packaging>jar</packaging>
<version>1.6.5</version>
<version>1.6.6</version>
<name>indy</name>
<description>This is the official SDK for Hyperledger Indy (https://www.hyperledger.org/projects),
which provides a distributed-ledger-based foundation for self-sovereign identity (https://sovrin.org).
@@ -1,6 +1,6 @@
{
"name": "indy-sdk",
"version": "1.6.5",
"version": "1.6.6",
"description": "Native bindings for hyperledger indy",
"author": "hyperledger",
"license": "Apache-2.0",
View
@@ -2,7 +2,7 @@
setup(
name='python3-indy',
version='1.6.5',
version='1.6.6',
packages=['indy'],
url='https://github.com/hyperledger/indy-sdk',
license='MIT/Apache-2.0',

0 comments on commit 531a2cf

Please sign in to comment.