Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Plugin breaks edit page on certain plugins. #59

Closed
bitzl opened this issue Mar 22, 2014 · 4 comments
Closed

Plugin breaks edit page on certain plugins. #59

bitzl opened this issue Mar 22, 2014 · 4 comments

Comments

@bitzl
Copy link

@bitzl bitzl commented Mar 22, 2014

Hi, first thanks for your great plugin. However, for some themes (Origami in my case) edit pages breaks:

Fatal error: Cannot redeclare aesop_shortcodes_blob() (previously declared in /var/www/clients/client1/web1/web/wp-content/plugins/aesop-story-engine/admin/includes/generator_blob.php:4) in /var/www/clients/client1/web1/web/wp-content/plugins/aesop-story-engine/admin/includes/generator_blob.php on line 66

When I switch to twenty thirteen, everything works fine. Editing posts works fine for both themes.

If I you need more information, just let me know.

@bearded-avenger
Copy link
Collaborator

@bearded-avenger bearded-avenger commented Mar 22, 2014

That's a first

@bearded-avenger
Copy link
Collaborator

@bearded-avenger bearded-avenger commented Mar 22, 2014

I suggest re-installing

@bearded-avenger
Copy link
Collaborator

@bearded-avenger bearded-avenger commented Mar 22, 2014

Scratch that, I have pulled down the theme and have replicated the issue. This only affects this theme. And this only affects editing pages.

I've isolated the issue to the plugin activation function within that themes functions.php file. If I comment it out completely, post editing comes back. I'm not sure what they are doing there, but whatever they are doing, is angering Aesop. Not sure if there's much I can do on my end at all.

// the include on line 11
include get_template_directory() . '/extras/plugin-activation/plugin-activation.php';

// and function on functions.php line 88
if(!defined('SITEORIGIN_PANELS_VERSION') && !siteorigin_plugin_activation_is_activating('siteorigin-panels')) {
        include get_template_directory().'/extras/panels/panels.php';
    }
@bitzl
Copy link
Author

@bitzl bitzl commented Mar 23, 2014

Thanks for your effort! I'll give it to the Origami support to fix it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants