New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error with client.unfocused on start #3449

Closed
TheDevKiller opened this Issue Oct 11, 2018 · 3 comments

Comments

Projects
None yet
3 participants
@TheDevKiller

TheDevKiller commented Oct 11, 2018

I'm submitting a…

[x] Bug
[ ] Feature Request
[ ] Documentation Request
[ ] Other (Please describe in detail)

Current Behavior

When I start i3, I have an error in my config file

Expected Behavior

No errors when I start i3

Reproduction Instructions

Use this in a config

# Colors
set_from_resource       $background       background
#set_from_resource       $theme-active     foreground
set_from_resource       $theme-inactive   trueblack
set $theme-active #27ae60

client.background             $background
client.focused          $theme-active   $theme-active   $theme-inactive $theme-active   $theme-active
client.focused_inactive $theme-inactive $theme-inactive $theme-active   $theme-active   $theme-inactive
client.unfocused        $theme-inactive $theme-inactive $theme-active   $theme-inactive $theme-inactive

Environment

Output of i3 --moreversion 2>&-:

Binary i3 version:  4.15.0.1 (03-13-2018) © 2009 Michael Stapelberg and contributors
Running i3 version: 4.15.0.1 (03-13-2018) (pid 862)bort…)
Loaded i3 config: /home/thedevkiller/.config/i3/config (Last modified: mer. 10 oct. 2018 20:51:18 CEST, 55613 seconds ago)

The i3 binary you just called: /usr/bin/i3
The i3 binary you are running: i3

Full config

https://pastebin.com/5v4FHxdy

Linux & compositor

- Linux Distribution & Version: Manjaro 17.1.12 Hakoila
- Are you using a compositor (e.g., xcompmgr or compton): compton
@i3bot

This comment has been minimized.

Show comment
Hide comment
@i3bot

i3bot Oct 11, 2018

I don’t see a link to logs.i3wm.org. Did you follow https://i3wm.org/docs/debugging.html? (In case you actually provided a link to a logfile, please ignore me.)

i3bot commented Oct 11, 2018

I don’t see a link to logs.i3wm.org. Did you follow https://i3wm.org/docs/debugging.html? (In case you actually provided a link to a logfile, please ignore me.)

@orestisf1993

This comment has been minimized.

Show comment
Hide comment
@orestisf1993

orestisf1993 Oct 11, 2018

Member

set_from_resource $<name> <resource_name> <fallback> (you can keep the whitespace)
name=$theme-inactive
resourcename=trueblack
fallback=(empty)

Is trueblack defined in your ~/.Xresources? If not, the `client.unfocused like will fail.

Member

orestisf1993 commented Oct 11, 2018

set_from_resource $<name> <resource_name> <fallback> (you can keep the whitespace)
name=$theme-inactive
resourcename=trueblack
fallback=(empty)

Is trueblack defined in your ~/.Xresources? If not, the `client.unfocused like will fail.

@TheDevKiller

This comment has been minimized.

Show comment
Hide comment
@TheDevKiller

TheDevKiller Oct 11, 2018

I don't have this file so I replaced theses lines (colors) by a simple set. It works, thank you

TheDevKiller commented Oct 11, 2018

I don't have this file so I replaced theses lines (colors) by a simple set. It works, thank you

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment