Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Switching containers does not work when dragging content from Firefox #3789

Open
reitzig opened this issue Sep 5, 2019 · 10 comments

Comments

@reitzig
Copy link

commented Sep 5, 2019

I'm submitting a…

[x] Bug
[ ] Feature Request
[ ] Documentation Request
[ ] Other (Please describe in detail)

Current Behavior

Dragging an object (text selection, image) from Firefox blocks switching containers and workspaces with $mod + number arrow keys.

Expected Behavior

While dragging, it should be possible to switch to another container (maybe on another workspace) so I can drop the content there.

Reproduction Instructions

  • Open two Firefox windows A, B and stack them.
  • Open a website with images in A, and Imgur in B.
  • (Try to) drag an image from A to B.

Workaround: Temporarily arrange A, B in a horizontal or vertical split. Then, drag & drop works.

Environment

Output of i3 --moreversion 2>&-:

Binary i3 version:  4.16.1 (2019-01-27) © 2009 Michael Stapelberg and contributors
Running i3 version: 4.16.1 (2019-01-27) (pid 2746)abort…)
Loaded i3 config: /home/raphael/.config/i3/config (Last modified: Do 05 Sep 2019 17:21:38 CEST, 626369 seconds ago)

The i3 binary you just called: /usr/bin/i3
The i3 binary you are running: i3

config

- Linux Distribution & Version: Ubuntu 18.04 LTS
- Are you using a compositor (e.g., xcompmgr or compton): no
- Firefox 69.0
@i3bot i3bot added the bug label Sep 5, 2019
@i3bot

This comment has been minimized.

Copy link

commented Sep 5, 2019

I don’t see a link to logs.i3wm.org. Did you follow https://i3wm.org/docs/debugging.html? (In case you actually provided a link to a logfile, please ignore me.)

@i3bot i3bot added the missing-log label Sep 5, 2019
@i3bot

This comment has been minimized.

Copy link

commented Sep 5, 2019

Sorry, we can only support the latest major version. Please upgrade from 4.14 to 4.17, verify the bug still exists, and re-open this issue.

@i3bot i3bot closed this Sep 5, 2019
@reitzig

This comment has been minimized.

Copy link
Author

commented Sep 5, 2019

Why thanks, so LTS users don't get to report issues? :/

@Airblader

This comment has been minimized.

Copy link
Member

commented Sep 5, 2019

There is no »i3 LTS«, LTS is an Ubuntu thing and we don't maintain Ubuntu. :-) Sorry that this is inconvenient, but it is simply too much effort for us to maintain old versions; we also do not have bugfix releases on those anyway, so to get a fix you'd need to update either way. We very much focus on compatibility, however, so we always recommend staying on the latest version. This is also possible on Ubuntu LTS by using a corresponding PPA.

@reitzig

This comment has been minimized.

Copy link
Author

commented Sep 5, 2019

I understand. Thanks for the answer!

I'll try and check out that PPA.

[snark]Reproduction time on this is probably lower than answer time... ;)[/snark]

@Airblader

This comment has been minimized.

Copy link
Member

commented Sep 5, 2019

We're patient :-)

@Airblader

This comment has been minimized.

Copy link
Member

commented Sep 5, 2019

For what it's worth, I just now tried my keybinding to switch focus on the stacked container while keeping an image dragged and that worked fine.

@reitzig

This comment has been minimized.

Copy link
Author

commented Sep 12, 2019

Can't confirm, still doesn't work for me (updated the issue). Dragging images from e.g. Thunar or Discord works fine, but not from Firefox.

@reitzig

This comment has been minimized.

Copy link
Author

commented Oct 7, 2019

@Airblader Given that 4.17 hasn't hit the PPA yet, can I do anything else to help?

@Airblader Airblader added 4.16 and removed unsupported-version labels Oct 8, 2019
@Airblader

This comment has been minimized.

Copy link
Member

commented Oct 8, 2019

I'll reopen tagged as 4.16 for now, but since it works for me on the current version you could try building i3 from source to see if that does fix it – or stay patient. :-)

@Airblader Airblader reopened this Oct 8, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.