Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

odd focus/resize behavior #3865

Open
cehteh opened this issue Nov 18, 2019 · 1 comment

Comments

@cehteh
Copy link

@cehteh cehteh commented Nov 18, 2019

I'm submitting a…

[x] Bug
[ ] Feature Request
[ ] Documentation Request
[ ] Other (Please describe in detail)

Current Behavior

Configuring the mouse wheel for resizing windows, focus_follows_mouse disabled

focus_follows_mouse no
bindsym --whole-window Mod1+Control+button4    resize grow height 10 px or 1 ppt; resize grow width 10 px or 1 ppt
bindsym --whole-window Mod1+Control+button5    resize shrink width 10 px or 1 ppt; resize shrink height 10 px or 1 ppt

Expected Behavior

  1. Open multiple windows in split or floating.
  2. Hoover the mouse over the focused window and then 'Mod1+Control+mousewheel' grows/shrinks the window as expected.

Reproduction Instructions

  1. Open multiple windows in split or floating.
  2. Hoover the mouse over a non focused window and then 'Mod1+Control+mousewheel'
    • Mod1+Control+button4 grows the focused window
    • Mod1+Control+button5 shrinks the window where the mouse is hoovering

This is quite inconsistent/inconvinient, on split windows, either mouse direction will only shrink the windows where the mouse is hoovering when it does not have focus. On floating it feels even more weird.

Environment

Output of i3 --moreversion 2>&-:

i3 version: 
Binary i3 version:  4.17.1 (2019-08-30, branch "4.17.1") © 2009 Michael Stapelberg and contributors
Running i3 version: 4.17.1 (2019-08-30, branch "4.17.1") (pid 16527)
Loaded i3 config: /home/ct/.i3/config (Last modified: So 17 Nov 2019 17:36:35 CET, 52175 seconds ago)

The i3 binary you just called: /usr/local/bin/i3
The i3 binary you are running: i3

The 3 lines for configuring focus/mousewheel above added to the default config cause this behavior.

Logfile URL:
n/a can provide one on demand.
- Linux Distribution & Version:
  * Debian 9.11
  * i3 build from source
- Are you using a compositor (e.g., xcompmgr or compton):
  * bug happens under compton as well without
@i3bot

This comment has been minimized.

Copy link

@i3bot i3bot commented Nov 18, 2019

I don’t see a link to logs.i3wm.org. Did you follow https://i3wm.org/docs/debugging.html? (In case you actually provided a link to a logfile, please ignore me.)

@i3bot i3bot added the 4.17 label Nov 18, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.