New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Decode in debug mode - Could not find superclass Ljava/lang/Object; #451

Closed
iBotPeaches opened this Issue Mar 18, 2015 · 2 comments

Comments

Projects
None yet
1 participant
@iBotPeaches
Owner

iBotPeaches commented Mar 18, 2015

Original issue 340 created by marcel44.k on 2012-08-09T19:14:53.000Z:

`--> apktool d -d myapp.apk
I: Baksmaling...

Error occured while loading boot class path files. Aborting.
org.jf.dexlib.Code.Analysis.ClassPath$ClassNotFoundException: Could not find superclass Ljava/lang/Object;
at org.jf.dexlib.Code.Analysis.ClassPath$ClassDef.loadSuperclass(ClassPath.java:832)
at org.jf.dexlib.Code.Analysis.ClassPath$ClassDef.<init>(ClassPath.java:685)
at org.jf.dexlib.Code.Analysis.ClassPath.loadClassDef(ClassPath.java:282)
at org.jf.dexlib.Code.Analysis.ClassPath.initClassPath(ClassPath.java:163)
at org.jf.dexlib.Code.Analysis.ClassPath.InitializeClassPath(ClassPath.java:131)
at org.jf.baksmali.baksmali.disassembleDexFile(baksmali.java:111)
at brut.androlib.src.SmaliDecoder.decode(SmaliDecoder.java:44)
at brut.androlib.src.SmaliDecoder.decode(SmaliDecoder.java:33)
at brut.androlib.Androlib.decodeSourcesSmali(Androlib.java:73)
at brut.androlib.ApkDecoder.decode(ApkDecoder.java:85)
at brut.apktool.Main.cmdDecode(Main.java:128)
at brut.apktool.Main.main(Main.java:65)

`--> apktool
Apktool v1.4.9.aed20bd - a tool for reengineering Android apk files
Copyright 2010 Ryszard Wiśniewski <brut.alll@gmail.com>
with smali v1.3.4-dev, and baksmali v1.3.4-dev
Updated by iBotPeaches (@iBotPeaches) and yyj
Apache License 2.0 (http://www.apache.org/licenses/LICENSE-2.0)

`--> uname -a
Linux 3.4.7-1-ARCH # 1 SMP PREEMPT Sun Jul 29 22:02:56 CEST 2012 x86_64 GNU/Linux

This only happen when I try decode using debug mode. Without debug mode apktool works fine.

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #1 originally posted by connor.tumbleson on 2012-11-15T17:29:03.000Z:

Confirmed.

Owner

iBotPeaches commented Mar 18, 2015

Comment #1 originally posted by connor.tumbleson on 2012-11-15T17:29:03.000Z:

Confirmed.

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #2 originally posted by connor.tumbleson on 2013-03-03T18:44:45.000Z:

Fixed in v1.5.3

Owner

iBotPeaches commented Mar 18, 2015

Comment #2 originally posted by connor.tumbleson on 2013-03-03T18:44:45.000Z:

Fixed in v1.5.3

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment