Cannot install vivo-res.apk framework #583

Closed
iBotPeaches opened this Issue Mar 18, 2015 · 4 comments

Comments

Projects
None yet
1 participant
@iBotPeaches
Owner

iBotPeaches commented Mar 18, 2015

Original issue 473 created by duphong.le on 2013-06-17T12:26:18.000Z:

What steps will reproduce the problem?

  1. apktool if framework-res.apk
  2. apktool if vivo-res.apk
    3.

What is the expected output? What do you see instead?
The vivo-res framework is not installed and the output is:

Exception in thread "main" brut.androlib.AndrolibException: Arsc file contains zero or multiple packages
at brut.androlib.res.decoder.ARSCDecoder$ARSCData.getOnePackage(ARSCDecoder.java:429)
at brut.androlib.res.AndrolibResources.installFramework(AndrolibResources.java:694)
at brut.androlib.Androlib.installFramework(Androlib.java:615)
at brut.apktool.Main.cmdInstallFramework(Main.java:248)
at brut.apktool.Main.main(Main.java:91)

What version of the product are you using? On what operating system?
I am using Ubuntu 12.04 and apktool 1.5.2

Please provide any additional information below.
You can find the framework files here
framewor-res.apk : https://docs.google.com/file/d/0B7WKaNefcJB-akdyQVFoVTlfbkU/edit?usp=sharing
vivo-res.apk : https://docs.google.com/file/d/0B7WKaNefcJB-eHFaUTg1dXZvRlU/edit?usp=sharing

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #1 originally posted by duphong.le on 2013-06-17T12:35:40.000Z:

Sorry these output logs are from apktool beta 2.0.0, on 1.5.2 they are
Exception in thread "main" brut.androlib.AndrolibException: Arsc file contains zero or multiple packages
at brut.androlib.res.decoder.ARSCDecoder$ARSCData.getOnePackage(ARSCDecoder.java:431)
at brut.androlib.res.AndrolibResources.installFramework(AndrolibResources.java:566)
at brut.androlib.Androlib.installFramework(Androlib.java:473)
at brut.apktool.Main.cmdInstallFramework(Main.java:250)
at brut.apktool.Main.main(Main.java:81)

Owner

iBotPeaches commented Mar 18, 2015

Comment #1 originally posted by duphong.le on 2013-06-17T12:35:40.000Z:

Sorry these output logs are from apktool beta 2.0.0, on 1.5.2 they are
Exception in thread "main" brut.androlib.AndrolibException: Arsc file contains zero or multiple packages
at brut.androlib.res.decoder.ARSCDecoder$ARSCData.getOnePackage(ARSCDecoder.java:431)
at brut.androlib.res.AndrolibResources.installFramework(AndrolibResources.java:566)
at brut.androlib.Androlib.installFramework(Androlib.java:473)
at brut.apktool.Main.cmdInstallFramework(Main.java:250)
at brut.apktool.Main.main(Main.java:81)

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #2 originally posted by connor.tumbleson on 2013-06-22T14:12:43.000Z:

Can't access those files.

Owner

iBotPeaches commented Mar 18, 2015

Comment #2 originally posted by connor.tumbleson on 2013-06-22T14:12:43.000Z:

Can't access those files.

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #3 originally posted by duphong.le on 2013-06-22T17:31:29.000Z:

your access to these files have been granted

Owner

iBotPeaches commented Mar 18, 2015

Comment #3 originally posted by duphong.le on 2013-06-22T17:31:29.000Z:

your access to these files have been granted

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #4 originally posted by connor.tumbleson on 2013-10-12T20:45:30.000Z:

Fixed in 2.0

http://git.io/Vjp8Ow

Owner

iBotPeaches commented Mar 18, 2015

Comment #4 originally posted by connor.tumbleson on 2013-10-12T20:45:30.000Z:

Fixed in 2.0

http://git.io/Vjp8Ow

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment