Compile errors for latest Swype #660

Closed
iBotPeaches opened this Issue Mar 18, 2015 · 5 comments

Comments

Projects
None yet
1 participant
@iBotPeaches
Owner

iBotPeaches commented Mar 18, 2015

Original issue 550 created by notmy51 on 2013-11-15T22:45:54.000Z:

What steps will reproduce the problem?

  1. Normal decompile and compile with no changes
  2. Have tried framework from 4.1.2, 4.3, and 4.4 and the one installed with apktool beta2.0
  3. Will try to help however I can

What is the expected output? What do you see instead?
No errors, maybe some aapt warnings

What version of the product are you using? On what operating system?
apktool_2.0.0b7.jar and apktool_1.5.2 Windows 8.1 with latest SDK, JRE, and API's

Please provide any additional information below.
Getting found dimen-array or fraction-array where item is expected, along with numerous Public symbol array errors

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #1 originally posted by notmy51 on 2013-11-15T22:47:12.000Z:

Forgot to add, no errors when de-compiling

Owner

iBotPeaches commented Mar 18, 2015

Comment #1 originally posted by notmy51 on 2013-11-15T22:47:12.000Z:

Forgot to add, no errors when de-compiling

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #2 originally posted by connor.tumbleson on 2013-11-22T22:42:49.000Z:

I don't think

dimen-array or fraction-array are valid. They should be either integer-array, string-array or array.

This is a problem. Let me do some research in AOSP to confirm those aren't valid, otherwise it seems apktool is assign the value the array based on the contents. Which in this case Apktool think its a dimensional array or fraction.

The fix would be (if my guess is correct) is too limit arrays.xml to only integer/string/array based on the values.

Owner

iBotPeaches commented Mar 18, 2015

Comment #2 originally posted by connor.tumbleson on 2013-11-22T22:42:49.000Z:

I don't think

dimen-array or fraction-array are valid. They should be either integer-array, string-array or array.

This is a problem. Let me do some research in AOSP to confirm those aren't valid, otherwise it seems apktool is assign the value the array based on the contents. Which in this case Apktool think its a dimensional array or fraction.

The fix would be (if my guess is correct) is too limit arrays.xml to only integer/string/array based on the values.

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #3 originally posted by notmy51 on 2013-11-23T00:47:10.000Z:

Found a solution by changing the dimen or fraction to string fire each error and was able to compile with no errors

Owner

iBotPeaches commented Mar 18, 2015

Comment #3 originally posted by notmy51 on 2013-11-23T00:47:10.000Z:

Found a solution by changing the dimen or fraction to string fire each error and was able to compile with no errors

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #4 originally posted by connor.tumbleson on 2013-11-23T14:36:03.000Z:

e91790e

Owner

iBotPeaches commented Mar 18, 2015

Comment #4 originally posted by connor.tumbleson on 2013-11-23T14:36:03.000Z:

e91790e

@iBotPeaches

This comment has been minimized.

Show comment
Hide comment
@iBotPeaches

iBotPeaches Mar 18, 2015

Owner

Comment #5 originally posted by thinh182009 on 2013-11-23T15:02:42.000Z:

apktool 2.0 final SP fix all....? hjhj

Owner

iBotPeaches commented Mar 18, 2015

Comment #5 originally posted by thinh182009 on 2013-11-23T15:02:42.000Z:

apktool 2.0 final SP fix all....? hjhj

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment