Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

How to really get Maximum Rates in Manual Mode #4895

Closed
MartinHugh opened this issue Jul 2, 2019 · 5 comments

Comments

Projects
None yet
4 participants
@MartinHugh
Copy link

commented Jul 2, 2019

I am using iNav2.1 with a 1m flying wing.

I am familiar with this airframe model with two different flight controllers (iNav and Vector) and without a flight controller at all.

I am noticing that with iNav the pitch and especially roll rates seem dumbed down.

Manual roll and pitch rates are set in iNav to 100%
Weights on all channels in the transmitter are set to 100%
There is no transmitter expo configured.

Is there something else I need to configure (like iNav expo?) or something else, to get to a real "manual" mode. What else could be affecting the performance?

Thanks.

@issue-label-bot

This comment has been minimized.

Copy link

commented Jul 2, 2019

Issue Label Bot is not confident enough to auto-label this issue. See dashboard for more details.

@MartinHugh MartinHugh changed the title Maximum Rates in Manual Mode How to really get Maximum Rates in Manual Mode Jul 2, 2019

@etulupov

This comment has been minimized.

Copy link

commented Jul 2, 2019

@MartinHugh
Seems your config is ok. Please ensure that Manual Mode was activated.

You can also debug servo pulse values on Motor tab. You should see values from MIN to MAX range (typically from 1000 us to 2000 us), when you move transmitter sticks.

@MartinHugh

This comment has been minimized.

Copy link
Author

commented Jul 2, 2019

@etulupov thank you for your response. Yes, Manual Mode is activated. I will check out the pulse values as you suggest.

@b14ckyy

This comment has been minimized.

Copy link

commented Jul 7, 2019

check your mixer settings. By default it is at 50% maximum mix. Set this higher till you get the same throw like with a normal servo receiver. Be careful not to put too much throw in it to avoid highspeed stall but i think you are experienced enough to know that :)

@MartinHugh

This comment has been minimized.

Copy link
Author

commented Jul 7, 2019

@b14ckyy thanks for the heads up on that - I will check it out.

@DzikuVx DzikuVx added the Support label Jul 16, 2019

@DzikuVx DzikuVx closed this Jul 16, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.