Dependency issues with chef 0.10.8 #27

Open
mugwump opened this Issue Feb 20, 2013 · 1 comment

Comments

Projects
None yet
2 participants

mugwump commented Feb 20, 2013

I'm not exactly sure what has change, it is probably an issue with one of minor-chef version, but I get a dependency-error for the chef-install with 0.10.8:

 * executing "sudo -p 'sudo password: ' gem install chef -v \"~> 0.10.8\" --quiet --no-ri --no-rdoc"
    servers: ["192.168.1.10"]
    [192.168.1.10] executing command
ERROR:  While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: chef requires net-ssh (~> 2.2.2); net-ssh-multi requires net-ssh (>= 2.1.4); net-ssh-gateway requires net-ssh (>= 2.6.5)
    command finished in 23491ms
failed: "env RAILS_ENV=production GIT_SSL_NO_VERIFY=true sh -c 'sudo -p '\\''sudo password: '\\'' gem install chef -v \"~> 0.10.8\" --quiet --no-ri --no-rdoc'" on 192.168.1.10

If updated the chef-reference to use 11.4.0&the error is gone. Not sure how much else this breaks, but this seems to be working for now...

tf commented Nov 26, 2013

Can confirm the issue. Also have it working with chef 11.4. No problems so far.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment