Skip to content
master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Sassy-validation

Sass validation library.

Documentation

Requirements

  • Ruby Sass <= v3.2
  • LibSass <= v3.1

Installation

Git:

git clone git@github.com:iamskok/sassy-validation.git ./

Bower:

bower install sassy-validation --save-dev

Examples

SassMeister Demo

validate(1em, measure)                  // returns true
validate(13, measure)                   // returns false
validate(77, number)                    // returns true
validate('77', number)                  // returns false
validate('sassy-validation', string)    // returns true
validate(1.618, float)                  // returns true
validate(1 2 3 4 5, list)               // returns true
validate(-99999, negative)              // returns true
validate(px, unit)                      // returns true

Credits

About

Type validation in Sass πŸ”¬

Topics

Resources

Packages

No packages published

Contributors 4

  •  
  •  
  •  
  •