Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

update to handle MEP11 setup issue with matplotlib

  • Loading branch information...
commit f67a819bd3a585ece21ceef3737786715f9fb3a2 1 parent e0c5415
@ianozsvald authored
Showing with 7 additions and 3 deletions.
  1. +3 −0  README.md
  2. +0 −3  requirements.txt
  3. +4 −0 requirements_2.txt
View
3  README.md
@@ -47,6 +47,9 @@ You also need the following:
The easy way to get these is to install:
$ pip install -r requirements.txt
+ $ pip install -r requirements_2.txt # installs matplotlib after numpy from first requirements file
+
+Note the above use of 2 requirements files is due to a matplotlib setup issue: https://github.com/matplotlib/matplotlib/wiki/MEP11
Usage:
-----
View
3  requirements.txt
@@ -1,10 +1,7 @@
argparse==1.2.1
distribute==0.6.24
numpy==1.7.0
-matplotlib==1.2.0
networkx==1.7
-pygraphviz==1.1
twitter-text-python==1.0.0.2
wsgiref==0.1.2
nltk==2.0.4
-ipython==0.13.1
View
4 requirements_2.txt
@@ -0,0 +1,4 @@
+matplotlib==1.2.0
+pygraphviz==1.1
+ipython==0.13.1
+
Please sign in to comment.
Something went wrong with that request. Please try again.