Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Fix each-component dependency #1

Merged
merged 2 commits into from

2 participants

@pirxpilot

I must have missed a memo on that but it looks like someone is in the middle of 'let's rename all bongo-component to component-bongo' operation.
This patch fixes component-outdated by setting dependency version to ~0.1 (the last published each-component version)
We can update later to the latest but the npm is acting out today and/or 'component-each' seems to have a set of unrelated problems.

pirxpilot added some commits
@pirxpilot pirxpilot fix each-component version in dependency
we had a dependency on github HEAD for each-component - but the name of
the module for each-component has been changed to component-each and, as
far as I can tell, the current version (1.0.0) has some other dependency problems
807f1b9
@pirxpilot pirxpilot fix repo reference in package.json 5cdb9d7
@pirxpilot pirxpilot referenced this pull request in ianstormtaylor/component-update
Merged

Fix each-component dependency #4

@ianstormtaylor ianstormtaylor merged commit 20b9ce0 into from
@ianstormtaylor

thanks! 0.0.3

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Feb 28, 2014
  1. @pirxpilot

    fix each-component version in dependency

    pirxpilot authored
    we had a dependency on github HEAD for each-component - but the name of
    the module for each-component has been changed to component-each and, as
    far as I can tell, the current version (1.0.0) has some other dependency problems
  2. @pirxpilot
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 2 deletions.
  1. 0  bin/component-outdated
  2. +2 −2 package.json
View
0  bin/component-outdated 100644 → 100755
File mode changed
View
4 package.json
@@ -1,6 +1,6 @@
{
"name": "component-outdated",
- "repository": "git://github.com/typefaces/component-outdated.git",
+ "repository": "git://github.com/ianstormtaylor/component-outdated.git",
"version": "0.0.2",
"license": "MIT",
"description": "A component command plugin to list outdated dependencies.",
@@ -16,7 +16,7 @@
"batch": "~0.5.0",
"commander": "1.0.5",
"component": "~0.17.6",
- "each-component": "git://github.com/component/each",
+ "each-component": "~0.1",
"pad-component": "0.0.1"
},
"bin": {
Something went wrong with that request. Please try again.