Permalink
Browse files

Move development deps into gemspec

  • Loading branch information...
1 parent 34b93f5 commit f131ca8acbd069e3107a70a47d7c0a783ad0e980 @ianwhite committed Jan 3, 2011
Showing with 27 additions and 71 deletions.
  1. +1 −12 Gemfile
  2. +26 −59 orm_adapter.gemspec
View
@@ -1,14 +1,3 @@
source "http://rubygems.org"
-group :development do
- gem "yard"
- gem "rake"
- gem "activerecord", "~> 3.0.3"
- gem "mongoid", "~> 2.0.0.beta.20"
- gem "bson_ext"
- gem "rspec", "~> 2.4.0"
- gem "sqlite3-ruby"
- gem "datamapper"
- gem "dm-sqlite-adapter"
- gem "dm-active_model"
-end
+gemspec
View
@@ -1,66 +1,33 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
-# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "orm_adapter/version"
Gem::Specification.new do |s|
- s.name = %q{orm_adapter}
- s.version = "0.0.3"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.name = "orm_adapter"
+ s.version = OrmAdapter::VERSION.dup
+ s.platform = Gem::Platform::RUBY
s.authors = ["Ian White", "Jose Valim"]
- s.date = %q{2010-10-12}
- s.description = %q{Provides a single point of entry for using basic features of ruby ORMs}
- s.email = %q{ian.w.white@gmail.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".gitignore",
- "Gemfile",
- "Gemfile.lock",
- "History.txt",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "lib/orm_adapter.rb",
- "lib/orm_adapter/adapters/active_record.rb",
- "lib/orm_adapter/adapters/data_mapper.rb",
- "lib/orm_adapter/adapters/mongoid.rb",
- "lib/orm_adapter/base.rb",
- "lib/orm_adapter/to_adapter.rb",
- "lib/orm_adapter/version.rb",
- "orm_adapter.gemspec",
- "spec/orm_adapter/adapters/active_record_spec.rb",
- "spec/orm_adapter/adapters/data_mapper_spec.rb",
- "spec/orm_adapter/adapters/mongoid_spec.rb",
- "spec/orm_adapter/example_app_shared.rb",
- "spec/orm_adapter_spec.rb",
- "spec/spec_helper.rb"
- ]
- s.homepage = %q{http://github.com/ianwhite/orm_adapter}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Provides a single point of entry for using basic features of ruby ORMs}
- s.test_files = [
- "spec/orm_adapter/adapters/active_record_spec.rb",
- "spec/orm_adapter/adapters/data_mapper_spec.rb",
- "spec/orm_adapter/adapters/mongoid_spec.rb",
- "spec/orm_adapter/example_app_shared.rb",
- "spec/orm_adapter_spec.rb",
- "spec/spec_helper.rb"
- ]
+ s.description = "Provides a single point of entry for using basic features of ruby ORMs"
+ s.summary = "orm_adapter provides a single point of entry for using basic features of popular ruby ORMs. Its target audience is gem authors who want to support many ruby ORMs."
+ s.email = "ian.w.white@gmail.com"
+ s.homepage = "http://github.com/ianwhite/orm_adapter"
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.rubyforge_project = "orm_adapter"
+ s.required_rubygems_version = ">= 1.3.6"
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- else
- end
- else
- end
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.require_paths = ["lib"]
+
+ s.add_development_dependency "bundler", ">= 1.0.0"
+ s.add_development_dependency "yard", ">= 0.6.0"
+ s.add_development_dependency "rake", ">= 0.8.7"
+ s.add_development_dependency "activerecord", ">= 3.0.0"
+ s.add_development_dependency "mongoid", ">= 2.0.0.beta.20"
+ s.add_development_dependency "bson_ext", ">= 1.1.5"
+ s.add_development_dependency "rspec", ">= 2.4.0"
+ s.add_development_dependency "sqlite3-ruby", ">= 1.3.2"
+ s.add_development_dependency "datamapper", ">= 1.0"
+ s.add_development_dependency "dm-sqlite-adapter", ">= 1.0"
+ s.add_development_dependency "dm-active_model", ">= 1.0"
end

0 comments on commit f131ca8

Please sign in to comment.