Skip to content
Browse files

Version 1.1.4 released.

  • Loading branch information...
1 parent 6702cb1 commit 00f2debdab07fd85e362f5e3e52f00dabd16117f @ibc committed Oct 9, 2012
Showing with 6 additions and 5 deletions.
  1. +4 −3 README.md
  2. +1 −1 lib/em/connection.rb
  3. +1 −1 lib/em/version.rb
View
7 README.md
@@ -59,17 +59,18 @@ the following features/fixes have been applied in EventMachine-LE:
* `EM::Protocols::SmtpServer`: support multiple messages per one connection and login auth type ([bogdan](https://github.com/eventmachine/eventmachine/pull/288)).
* Reimplement `EM::Queue` to avoid shift/push performance problem ([grddev](https://github.com/eventmachine/eventmachine/pull/311)).
* Many code cleanups.
-* New `EM::Connection` option for the `start_tls()` method: `:use_tls` (when true TLS version is used, SSL otherwise).
+* New `EM::Connection` option for `start_tls()` method: `:ssl_version` (valid values are `:SSLv23`, `:SSLv3` and `:TLSv1`, default value is `:SSLv23`).
+* New `EM::Connection` option for `start_tls()` method: `:cipher_list` (valid values are any [OpenSSL cipher string](http://www.openssl.org/docs/apps/ciphers.html#CIPHER_LIST_FORMAT), default value is `"ALL:!ADH:!LOW:!EXP:!DES-CBC3-SHA:@STRENGTH"`).
## Installation ##
-The Current stable version is eventmachine-le-1.1.0 (published as Ruby Gem), installable via:
+The Current stable version is eventmachine-le-1.1.4 (published as Ruby Gem), installable via:
<pre>
gem install eventmachine-le
</pre>
-If you want the beta version (not fully tested) install it by using `--pre` option:
+If you want the last beta version (not fully tested) install it by using `--pre` option:
<pre>
gem install eventmachine-le --pre
</pre>
View
2 lib/em/connection.rb
@@ -393,7 +393,7 @@ def connection_completed
# If true, the {#ssl_verify_peer} callback on the {EventMachine::Connection} object is called with each certificate
# in the certificate chain provided by the peer. See documentation on {#ssl_verify_peer} for how to use this.
#
- # @option args [Symbol] :ssl_version (:SSLv23) indicates the version of SSL to use. Valid values are :SSLv23, :SSLv3 and TLSv1. Default value is :SSLv23.
+ # @option args [Symbol] :ssl_version (:SSLv23) indicates the version of SSL to use. Valid values are :SSLv23, :SSLv3 and :TLSv1. Default value is :SSLv23.
#
# @option args [String] :cipher_list ("ALL:!ADH:!LOW:!EXP:!DES-CBC3-SHA:@STRENGTH") indicates the available SSL cipher values. Default value is "ALL:!ADH:!LOW:!EXP:!DES-CBC3-SHA:@STRENGTH". Check the format of the OpenSSL cipher string at http://www.openssl.org/docs/apps/ciphers.html#CIPHER_LIST_FORMAT.
#
View
2 lib/em/version.rb
@@ -1,3 +1,3 @@
module EventMachine
- VERSION = "1.1.4.beta.2"
+ VERSION = "1.1.4"
end

0 comments on commit 00f2deb

Please sign in to comment.
Something went wrong with that request. Please try again.