Skip to content
Browse files

I removed "require 'rubyeventmachine'" (the C extension). Aded again.…

… Some other minimal improvements.
  • Loading branch information...
1 parent f0c6a2d commit 063c3c6debff5e1d7e2ac4a26f24ba5400cb74a3 @ibc committed Feb 24, 2012
Showing with 6 additions and 5 deletions.
  1. +2 −2 Rakefile
  2. +0 −1 eventmachine-le.gemspec
  3. +2 −0 lib/eventmachine.rb
  4. +2 −2 rakelib/package.rake
View
4 Rakefile
@@ -1,10 +1,10 @@
require 'rubygems'
-GEMSPEC = Gem::Specification.load('eventmachine.gemspec')
+GEMSPEC = Gem::Specification.load('eventmachine-le.gemspec')
require 'rake/clean'
task :clobber => :clean
-desc "Build eventmachine, then run tests."
+desc "Build eventmachine-le, then run tests."
task :default => [:compile, :test]
desc 'Generate documentation'
View
1 eventmachine-le.gemspec
@@ -5,7 +5,6 @@ Gem::Specification.new do |s|
s.name = 'eventmachine-le'
s.version = EventMachine::VERSION
s.homepage = 'https://github.com/ibc/EventMachine-LE/'
-# s.rubyforge_project = 'eventmachine'
s.authors = ["Francis Cianfrocca", "Aman Gupta", "hacked by Carsten Bormann and Inaki Baz Castillo"]
s.email = ["garbagecat10@gmail.com", "aman@tmm1.net", "cabo@tzi.org", "ibc@aliax.net"]
View
2 lib/eventmachine.rb
@@ -1,3 +1,5 @@
+require 'rubyeventmachine'
+
require 'em/version'
require 'em/pool'
require 'em/deferrable'
View
4 rakelib/package.rake
@@ -1,4 +1,4 @@
-require 'rake/gempackagetask'
+require 'rubygems/package_task'
begin
require 'rake/extensiontask'
require 'rake/javaextensiontask'
@@ -12,7 +12,7 @@ rake-compiler gem seems to be missing. Please install it with
MSG
end
-Rake::GemPackageTask.new(GEMSPEC) do |pkg|
+Gem::PackageTask.new(GEMSPEC) do |pkg|
end
if RUBY_PLATFORM =~ /java/

0 comments on commit 063c3c6

Please sign in to comment.
Something went wrong with that request. Please try again.