Permalink
Commits on Feb 5, 2015
  1. Add a deprecation warning to the readme

    [ci skip]
    committed Feb 5, 2015
  2. Remove jruby-openssl from the bundle

    It only causes problems with modern JRubies.
    
    Also change the source to rubygems.org
    committed Feb 5, 2015
  3. Version bump to v1.4.1

    committed Feb 5, 2015
  4. Rework stringio workaround

    In JRuby 9K, the Java class was moved, and instead of writing too many
    lines of Java-reflection code to keep the logic, the same logic was
    implemented by dispatching through Ruby means.
    
    I haven't verified whether the workaround is even necessary in JRuby 9K,
    so it might turn out that this is the wrong thing to do.
    grddev committed Feb 5, 2015
Commits on Jul 11, 2014
  1. Avoid copying byte arrays when packing/unpacking

    For the packer, packRaw creates a new byte array, so we can certainly
    avoid this copy.
    
    For the unpacker, we rely on the java-library that returns a new copy
    inside the unpacker. The low-level interface used by MessagePackLibrary
    is also safe, as all inputs are duplicated there as well.
    grddev committed Jul 11, 2014
Commits on Feb 12, 2014
  1. Version bump to v1.4.0

    committed Feb 12, 2014
  2. Add .dump and .load for ActiveRecord compatibility

    This closes #12
    committed Feb 12, 2014
  3. Attempt to use bundler.rubygems.org directly

    This should avoid endless redirect loop in bundler
    grddev committed with Nov 14, 2013
  4. Twiddle around with Ruby versions

    * Remove .rvmrc in favour of (private) .ruby-{version,gemset}.
    * Change Travis config to run in "jruby" and only jdk7, because installing exact versions of jruby no longer works, and jdk6 isn't supported either.
    committed Feb 12, 2014
Commits on Nov 14, 2013
  1. Version bump to v1.4.0.pre2

    grddev committed Nov 14, 2013
  2. Disable a lot of travis tests

    Don't run 1.8-mode as it does not work with "encode!"
    Don't run jruby 1.6.8 as bundler gets stuck in an endless redirect loop
    grddev committed Nov 14, 2013
  3. Add support for JRuby-1.7.{5,6}

    The method RubyString.encode_bang(ThreadContext) was removed, so call
    the array version with an empty array instead.
    grddev committed Nov 14, 2013
Commits on Oct 28, 2013
  1. Version bump to v1.4.0.pre1

    This is the same as pre0, but it seems like it got corrupted on its way to Rubygems.
    committed Oct 28, 2013
Commits on Sep 1, 2013
  1. Bump version to 1.4.0pre0

    grddev committed with Aug 9, 2013
  2. Merge commit 'encoding_fixes'

    committed Sep 1, 2013
Commits on Aug 7, 2013
Commits on Aug 6, 2013
  1. Added license to the gemspec

    committed Aug 6, 2013
  2. Clarified the copyright

    committed Aug 6, 2013
  3. Fix test descriptions

    grddev committed with Aug 5, 2013
  4. Trimmed down the build matrix some

    [ci skip]
    committed Aug 6, 2013