New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't use Newtonsoft.Json #817

Open
Bizarrus opened this Issue Jun 13, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@Bizarrus

Bizarrus commented Jun 13, 2018

How i can use Newtonsoft.Json in SharpDevelop on my WPF-Application?

Informations

SharpDevelop Version : 5.1.0.5216-0e58df71
.NET Version         : 4.7.03056
OS Version           : Microsoft Windows NT 6.3.9600.0
Current culture      : German (Germany) (de-DE)
Running under WOW6432, processor architecture: x86-64
Working Set Memory   : 329788kb
GC Heap Memory       : 97095kb

When i try to add the package over Project > Manage Packages... following error appears:

'Newtonsoft.Json' already has a dependency defined for 'Microsoft.CSharp`.

By using using Newtonsoft.Json;, SharpDevelop says:

Using directive is unnecessary.
The type or namespace name 'Newtonsoft' could not be found (are you missing a using directive or an assembly reference?)

Update

When i try to install the "depencie"/"higher package", it will shown following errors:

Json.NET
    > Microsoft.CSharp
        > NETStandard.Library
            > Microsoft.NETCore.Platforms
                > The 'Microsoft.NETCore.Platforms 2.1.0' package requires NuGet client version '2.12' or above, but the current NuGet Version is '2.8.60723.765'.
@fretelweb

This comment has been minimized.

fretelweb commented Jun 13, 2018

@linquize

This comment has been minimized.

Contributor

linquize commented Jun 14, 2018

Your dll is for .net core, not .net framework.
why did you use SharpDevelop for .net core?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment