Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

update test sdk and nunit packages to the curent versions. #359

Merged
merged 1 commit into from Jun 20, 2019

Conversation

Projects
None yet
3 participants
@Numpsy
Copy link
Contributor

commented Jun 19, 2019

I tried running code coverage on the unit tests with Visual Studio 2019 and found that it didn't work, which I think is down to limitations of the old packages with the .NET Core tests.

Any objections to updating the SDK and NUnit packages in the test projects to the current versions where it works ok?

I certify that I own, and have sufficient rights to contribute, all source code and related material intended to be compiled or integrated with the source code for the SharpZipLib open source product (the "Contribution"). My Contribution is licensed under the MIT License.

@christophwille

This comment has been minimized.

Copy link
Member

commented Jun 20, 2019

If the updates work with downlevel (VS2017) then this is fine.

@Numpsy

This comment has been minimized.

Copy link
Contributor Author

commented Jun 20, 2019

It works for me in VS2017 / 15.9, I don't have any earleir 2017 versions to hand to try though.

@christophwille

This comment has been minimized.

Copy link
Member

commented Jun 20, 2019

If it works in 15.9 that's ok. @piksel please merge.

@piksel piksel merged commit 1435683 into icsharpcode:master Jun 20, 2019

1 check passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details

@Numpsy Numpsy deleted the Numpsy:rw/coverage branch Jun 20, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.