Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

!bug: upload func. not work with Community 2.6

The community plugin (2.6) has a new setting to know whether
its function is enabled (for a user?). This setting seems to
be turnt off by default (FIXME: how to turn it on?), and that
will hide the "Upload link". Because IPM has its link displayed
by Community plugin, the upload func. seems not to work
  • Loading branch information...
commit cb10d77414b3213030d9226799c6ec308a211332 1 parent f94545c
@icy authored
Showing with 2 additions and 0 deletions.
  1. +2 −0  include/functions_icy_picture_modify.inc.php
View
2  include/functions_icy_picture_modify.inc.php
@@ -495,6 +495,8 @@ function icy_acl_fix_community($force = FALSE) {
$return['create_categories'] = icy_acl_get_real_value("create_gallery_to");
$return['permission_ids'] = array();
$return['icy_acl_fixed'] = 1;
+ /* Since Community 2.6 (!?), this setting is required for user */
+ $return['community_enabled'] = 20140201;
$_SESSION['community_user_permissions'] = $return;
$_SESSION['community_cache_key'] = $cache_key;

1 comment on commit cb10d77

@mjot

This seams not to work. I've problems to use the upload function. If icy_picture_modify is enabled.the add_photos page is empty. After disabling Icy Picture Modify it is working again. Could you please check this?

Thanks

Please sign in to comment.
Something went wrong with that request. Please try again.