Permalink
Browse files

+ missing </a> tag for edit button

For some reason I did not provide a closing tag for
the edit button, so some users will encounter problem
when the page is displayed.

Special thanks to Flop25 at gmail dot com
  • Loading branch information...
1 parent ddfe89c commit e70199796cdda8d79dcd8bce5cba0f8642c564d8 @icy committed Aug 18, 2013
Showing with 8 additions and 2 deletions.
  1. +5 −0 CHANGELOG
  2. +1 −0 README.md
  3. +2 −2 main.inc.php
View
@@ -1,3 +1,8 @@
+2.4.2 2013-08-18
+
+ - Fix a missing HTML tag (`a`) that is used to display `edit` button.
+ Special thanks `flop25` (flop25 at gmail dot com)
+
2.4.1 2013-08-14
- Fix security issue IPM-SA-2013-08-14. Details can be found in
View
@@ -138,6 +138,7 @@
* delakut _(Piwigo forum)_
* IGraham _(Piwigo forum)_
* Kalle _(Piwigo forum)_ *IPM-SA-2013-08-13*
+ * Flop25 _(flop25 at gmail dot com)_
## License
View
@@ -1,7 +1,7 @@
<?php
/*
Plugin Name: Icy Modify Picture
-Version: 2.4.1
+Version: 2.4.2
Description: Allow normal users to upload / modify pictures
Plugin URI: http://piwigo.org/ext/extension_view.php?eid=563
Author: icy
@@ -100,7 +100,7 @@ function icy_picture_modify_loc_begin_picture()
// this just makes this plugin sucks. Using new style? Like this?
// What a boring f***cking style I have to find another way
// FIXME: + translation here
- $url_admin = "<a href=\"$url_admin\" title=\"Modify information\" class=\"pwg-state-default pwg-button\" rel=\"nofollow\"> <span class=\"pwg-icon pwg-icon-edit\"> </span><span class=\"pwg-button-text\">Edit</span>";
+ $url_admin = "<a href=\"$url_admin\" title=\"Modify information\" class=\"pwg-state-default pwg-button\" rel=\"nofollow\"> <span class=\"pwg-icon pwg-icon-edit\"> </span><span class=\"pwg-button-text\">Edit</span></a>";
$template->add_picture_button($url_admin, 0);
}
}

0 comments on commit e701997

Please sign in to comment.