Atom Build provider for sass, compiles Sass/SCSS
JavaScript
Latest commit 6ec2e87 Jan 18, 2017 @idleberg Prepare 0.8.1 release
Permalink
Failed to load latest commit information.
lib
.eslintrc
.gitignore
.jshintrc
.travis.yml
LICENSE.md
README.md
coffeelint.json
gulpfile.js use Gulp v4 linter Dec 7, 2016
package.json
screenshot.png
yarn.lock update devDependencies Jan 18, 2017

README.md

build-sass

apm apm apm Travis David David

Atom Build provider for sass, compiles Sass/SCSS into CSS. Supports the linter package for error highlighting.

If you prefer LibSass, take note of the separate build-sassc package. When in doubt, consult the Sass Compatibility chart.

Screenshot

See the linter in action

Installation

apm

Install build-sass from Atom's Package Manager or the command-line equivalent:

$ apm install build-sass

Using Git

Change to your Atom packages directory:

# Windows
$ cd %USERPROFILE%\.atom\packages

# Linux & macOS
$ cd ~/.atom/packages/

Clone repository as build-sass:

$ git clone https://github.com/idleberg/atom-build-sass build-sass

Inside the cloned directory, install Node dependencies:

$ yarn || npm install

Usage

Build

Before you can build, select an active target with your preferred build option.

Available targets:

  • Sass [compact|compressed|expanded|user]
  • Watch Sass [compact|compressed|expanded]
  • SCSS [compact|compressed|expanded|user]
  • Watch SCSS [compact|compressed|expanded]

Shortcuts

Here's a reminder of the default shortcuts you can use with this package:

Select active target

Cmd+Alt+T or F7

Build script

Cmd+Alt+B or F9

Jump to error

Cmd+Alt+G or F4

Toggle build panel

Cmd+Alt+V or F8

License

This work is licensed under the The MIT License.

Donate

You are welcome support this project using Flattr or Bitcoin 17CXJuPsmhuTzFV2k4RKYwpEHVjskJktRd