New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Possible conflict with Core Like and KnownReactions Plugin #1753

Open
chrisaldrich opened this Issue May 18, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@chrisaldrich
Contributor

chrisaldrich commented May 18, 2017

While trying to do this:

Update to Known v0.9.9

I encountered this error:

Likes and reposts previously displayed properly on my site using the KnownReactions plugin are broken and/or don't display at all/properly.

  • Likes are treated as if they're bookmarks (including markup) and aren't wrapped with anchors to actually create links.
  • Reposts just don't display any previously extant content at all.
  • Trying to create new Likes or Reposts isn't possible and the UI shows up as if one is attempting to create a bookmark instead.

Some other notes:

This is a previously seen issue going back almost a year with relation to the KnownReactions plugin and there's also a thread describing the same problem(s) here: kylewm/KnownReactions#17

I thought I'd also post this in the issue queue here to get some additional eyeballs on it, particularly as it appears that there's potentially some relation to changes in the core "Like" (aka Bookmark) plugin since 0.9.2 which have occurred since the issue began.

Ideally, unless there are licensing or other issues (ie does @kylewm mind?), I would have expected that given the ubiquity of like/repost functionality, that all of KnownReactions might have all been rolled up into core in v0.9.9 or might be for v1.0.

From what I can tell, people, like me, who were using the released version of 0.9.2 didn't have any problems, but those using the master branch since then have. At some point it appears there was some code added to the "Like" core plugin that also allowed "likes" and "reposts" into the arrays along with "bookmarks" (for use in an more integrated UI using the bookmarklet to allow switching between SHARE, REPLY, BOOKMARK, RSVP, LIKE, and REPOST). I have a suspicion that it's some sort of conflict between this code in core and the KnownReactions code which is causing issues with prior likes and reposts from being displayed properly or being input at all in v0.9.9. I and several others have all looked at this with no one seeing anything obvious.

I also have feeling that some of the renaming within core when the core "Like" plugin functionally
really became the bookmark plugin haven't helped matters at all.

Give us some context, it'd also be really handy if you could tell us the contents of your version.known file
version = "0.9.9"
build = 2017051501

@dg01d

This comment has been minimized.

Show comment
Hide comment
@dg01d

dg01d May 24, 2017

Possibly related to this:

I turned debugging up to 4 while working on a new plugin. Saw many many errors in the PHP logs afterwards, all of the form:

PHP message: Known (hylozoist.ascraeus.org): notice - PHP [8] Undefined variable: rel in /srv/known/IdnoPlugins/Like/templates/default/entity/Like.tpl.php:32

Offending line is:

    <h2 class="idno-bookmark"><?=$icon?><a href="<?= $vars['object']->body; ?>" class="<?= $class ?> p-name"
                 target="_blank"><?= $this->parseURLs(htmlentities(strip_tags($body)), $rel) ?></a>
             </h2>

dg01d commented May 24, 2017

Possibly related to this:

I turned debugging up to 4 while working on a new plugin. Saw many many errors in the PHP logs afterwards, all of the form:

PHP message: Known (hylozoist.ascraeus.org): notice - PHP [8] Undefined variable: rel in /srv/known/IdnoPlugins/Like/templates/default/entity/Like.tpl.php:32

Offending line is:

    <h2 class="idno-bookmark"><?=$icon?><a href="<?= $vars['object']->body; ?>" class="<?= $class ?> p-name"
                 target="_blank"><?= $this->parseURLs(htmlentities(strip_tags($body)), $rel) ?></a>
             </h2>
@pvagner

This comment has been minimized.

Show comment
Hide comment
@pvagner

pvagner Jun 28, 2017

I can't figure this either. I've blindly upgraded my site about a month. I had loads of likes there and now all of them are withouth links. Does someone have at least a simple hint on how to go about tweaking this somehow?

pvagner commented Jun 28, 2017

I can't figure this either. I've blindly upgraded my site about a month. I had loads of likes there and now all of them are withouth links. Does someone have at least a simple hint on how to go about tweaking this somehow?

@chrisaldrich

This comment has been minimized.

Show comment
Hide comment
@chrisaldrich

chrisaldrich Jan 25, 2018

Contributor

@pvagner @benwerd @mapkyca @rMdes_ @Andrea @mruncieman @_dgoldsmith @TechLifeWeb @nxD4n I'm tempted to offer a bounty to see if we can't fix/reconcile difference in bookmarks/likes in @withknown core & that in @kylewmahan's Known Reactions. cross ref: kylewm/KnownReactions#17

Contributor

chrisaldrich commented Jan 25, 2018

@pvagner @benwerd @mapkyca @rMdes_ @Andrea @mruncieman @_dgoldsmith @TechLifeWeb @nxD4n I'm tempted to offer a bounty to see if we can't fix/reconcile difference in bookmarks/likes in @withknown core & that in @kylewmahan's Known Reactions. cross ref: kylewm/KnownReactions#17

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment