Doesn't work with PyCharm #187

Closed
zhanghuangbin opened this Issue Mar 7, 2013 · 19 comments

Projects

None yet

7 participants

@zhanghuangbin

Dear developer,

The latest 0.4.1 doesn't work with PyCharm (https://www.jetbrains.com/pycharm/), any plan to make it work? PyCharm is another IDE from JetBrains.

Thanks very much for your great work. :)

@behrad

I am also using Jetbrains Webstorm which 04.X is not being installed in. How can I hack it to work under Webstorm/Pycharm ?

@andrzejsliwa

same problem for RubyMine

@ignatov
Owner

Hi all.
Sure, it's possible to make the Erlang plugin compatible with all IntelliJ Platform IDEs. But PyCharm and RubyMine disallow to use custom SDKs and module types (in particular Erlang SDK and Erlang module type). Without SDK and custom module type the plugin will loss a lot of functionality (it will be an editor with highlighting). I'm not sure that it's a good idea. Thoughts?

@behrad
@Morgul

Honestly, I think that there's some use cases for just having highlighting/editor support. For example, I work on an Erlang server that has a python client; I use PyCharm for client development and occasionally I need to open the config for the server, or maybe just need to do some minor edits to the server. Any major development, and I currently pull up gvim. It'd be nice if my Erlang files had syntax highlighting, at the very least. It'd be nice if it was fully supported, but since that's not likely to happen, I think some functionality is better than none.

@ignatov
Owner

@Morgul Thanks, got it.

@ignatov
Owner

Hi all,
The latest plugin version is built for 129 branch, as far as I know that branch will be used for IntelliJ IDEA 12.1, PyCharm 2.7, PhpStorm/WebStorm 6 and RubyMine 5.4. For further information see IDEADEV space.

@ignatov ignatov closed this Apr 8, 2013
@behrad

Anybody tested this? To be 129 branch compatible, I downloaded Pycharm 2.7 EPA, and also Webstorm 6.0.2 from nightly builds and installed (current released downloads are 125 and 127 branch), when plugin is intalled PyCharm is unable to start and open, Webstorm opens but project can not be loaded!

@ignatov
Owner

@behrad I've just downloaded the latest Pytharm 129.258 and it's impossible to setup the Erlang plugin. Reopened.

@ignatov ignatov reopened this Apr 14, 2013
@behrad
@vlasovskikh

@ignatov See the log file with an exception from a PyCharm user in PY-9601.

@ignatov ignatov added a commit that closed this issue Apr 22, 2013
@ignatov fixed #187 da6b7e1
@ignatov ignatov closed this in da6b7e1 Apr 22, 2013
@ignatov
Owner

Hi, @all. Please checkout the latest build (199) from the build folder.

@jmarksharkey

Hey,

I've just downloaded and am evaluating WS and IntelliJ for erlang development. I tried to install the erlang plugin on both.. no problem in IntelliJ, but in WS it doesn't show up in the "Browse Repositories" list. I then tried downloading the latest build (199) and others, but am getting a "plugin incompatible with current installation" error message when I trie to install it.

Any ideas what could be causing this?

@ignatov
Owner
@jmarksharkey

ah yes.. 6.0.1

@ignatov
Owner
@jmarksharkey
@ignatov
Owner

The latest build is compatible with 129.* branch. I think it should be 6.* WS version.

@jmarksharkey

That was it.. found it on an EAP page. Thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment