Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update to Converse 5.0.1 #17

Closed
guusdk opened this issue Aug 9, 2019 · 7 comments

Comments

@guusdk
Copy link
Member

commented Aug 9, 2019

Converse has a new release, 5.0.0, which brings a lot of changes. We should update to https://github.com/conversejs/converse.js/releases/tag/v5.0.0

@deleolajide

This comment has been minimized.

Copy link
Member

commented Aug 9, 2019

Mam is not working. It will require a bit of testing before Inverse or Pade works with this version

@guusdk

This comment has been minimized.

Copy link
Member Author

commented Aug 9, 2019

MAM appears to be working on https://xmpp.igniterealtime.org:7483/inverse/, which is now running the 5.0.0 code, in the open_chat room.

Monitoring plugin v1.8.0 should fix MUC MAM issues. There's a known issue with one-on-one chats and MAM, but that issue was already there - it's not introduced by 5.0.0.

@deleolajide

This comment has been minimized.

Copy link
Member

commented Aug 9, 2019

I got "mam not supported by this server messages". I will check again with 4.4

@deleolajide

This comment has been minimized.

Copy link
Member

commented Aug 10, 2019

I am now getting messages, but I am still getting the errors.

image

@guusdk guusdk changed the title Update to Converse 5.0.0 Update to Converse 5.0.1 Aug 15, 2019

@guusdk

This comment has been minimized.

Copy link
Member Author

commented Aug 15, 2019

@jcbrand is putting out releases faster than we can process them. 5.0.1 is out: https://github.com/conversejs/converse.js/releases/tag/v5.0.1

@guusdk

This comment has been minimized.

Copy link
Member Author

commented Aug 15, 2019

The issues reported by @deleolajide are likely caused by a combination of these issues:

guusdk added a commit to guusdk/openfire-inverse-plugin that referenced this issue Aug 27, 2019
guusdk added a commit to guusdk/openfire-inverse-plugin that referenced this issue Aug 27, 2019
guusdk added a commit that referenced this issue Aug 27, 2019
@wrooot

This comment has been minimized.

Copy link
Member

commented Sep 11, 2019

inVerse is at 5.0.1.1. Shouldn't this be closed then?

@guusdk guusdk closed this Sep 11, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.