Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

HSQLDB upgrade script fails #9

Closed
wrooot opened this issue Jun 6, 2019 · 7 comments

Comments

@wrooot
Copy link
Member

@wrooot wrooot commented Jun 6, 2019

Looks like HSQLDB uses alter instead of modify.

wrooot added a commit to wrooot/openfire-userStatus-plugin that referenced this issue Jun 6, 2019
wrooot added a commit that referenced this issue Jun 7, 2019
#9 change modify to alter
@wrooot wrooot closed this Jun 7, 2019
@pras14587

This comment has been minimized.

Copy link

@pras14587 pras14587 commented Nov 15, 2019

What happen, when not updated the plugin?
Please share.
Is it reverse compatible?

@wrooot

This comment has been minimized.

Copy link
Member Author

@wrooot wrooot commented Nov 15, 2019

Not sure what you mean. This change is only in new version of plugin and this only affects when updating database. Do you want to update database, but still use older plugin? I think it should work as only database fields were updated to store longer values, no change to plugin itself as far as I remember.

@pras14587

This comment has been minimized.

Copy link

@pras14587 pras14587 commented Nov 18, 2019

Okay thanks, means things are reverse compatible.
If I update the plugin, there is no need to update the database,

@wrooot

This comment has been minimized.

Copy link
Member Author

@wrooot wrooot commented Nov 18, 2019

If you update the plugin, it will update the database. To be precise, it will update some fields related to UserStatus plugin in the database to let it store longer IPv6 strings.

@pras14587

This comment has been minimized.

Copy link

@pras14587 pras14587 commented Nov 18, 2019

yes, thank you so much.

@pras14587

This comment has been minimized.

Copy link

@pras14587 pras14587 commented Nov 21, 2019

Hi wroot, I want to implement chat using BOSH for Desktop, as per me you have also contributed on converse.js. I am facing many disconnection issues using Strophe js.
So, please help me out.

@wrooot

This comment has been minimized.

Copy link
Member Author

@wrooot wrooot commented Nov 21, 2019

This is not a place for such inquiry. Please use forums for this.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.