Skip to content
A ready-to-use platform for Node.js web apps, built on top of Express.
TypeScript JavaScript CoffeeScript Makefile HTML
Branch: master
Clone or download

Latest commit

Fetching latest commit…
Cannot retrieve the latest commit at this time.

Files

Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
docs
plugins/legacy
src
test
.gitignore
.nojekyll
.npmignore
.travis.yml
CNAME
History.md
Makefile
README.md
package-lock.json
package.json
settings.default.json
tsconfig.json

README.md

Expresser

Build Status Coverage Status

A Node.js framework built on top of Express.

Why Expresser?

Building on top of Express with added logging, utilities and extra plugins. The idea of Expresser is to aggregate all these common modules and utilities into a single package, making it damn easy to create your new Node.js app.

Use Expresser if...

  • You're new to Node.js web apps
  • You're familiar with Express.js
  • You want to use a similar codebase on your Node.js apps

Look elsewhere if...

  • You hate Express.js
  • You hate TypeScript
  • You need ultimate performance and as little overhead as possible

Major breaking changes on v4

Expresser is being rebuilt! CoffeeScript gives way to TypeScript. All-in-one gives way to only-what-you-need. Apps using Expresser v3.x.x will most certaiinly need to be updated.

To make the upgrade-path easier, you might use the expresser-legacy module while you change your app's code to use the recommended replacement features. More info here: https://github.com/igoramadas/expresser/wiki/Migration-from-v3-to-v4

API documentation

You can browse the full API documentation at https://expresser.devv.com.

You can’t perform that action at this time.