Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Delete Gemfile.lock from git and ignore it. #18

Merged
merged 1 commit into from

2 participants

Caius Durling Ilya Grigorik
Caius Durling

It shouldn't be committed for gem repos. Your gemspec should contain all the version requirements for gems ideally, so what's pinned in the Gemfile.lock is pretty irrelevant. (As I understand it.)

Yehuda wrote more on the subject, complete with a nice TL;DR to start the post off: http://yehudakatz.com/2010/12/16/clarifying-the-roles-of-the-gemspec-and-gemfile/

Caius Durling caius Delete Gemfile.lock from git and ignore it.
It shouldn't be committed for gem repos. Your gemspec should contain all the version requirements for gems ideally, so what's pinned in the Gemfile.lock is pretty irrelevant. (As I understand it.)
ddd62c7
Ilya Grigorik igrigorik merged commit 6623fa7 into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on May 30, 2012
  1. Caius Durling

    Delete Gemfile.lock from git and ignore it.

    caius authored
    It shouldn't be committed for gem repos. Your gemspec should contain all the version requirements for gems ideally, so what's pinned in the Gemfile.lock is pretty irrelevant. (As I understand it.)
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 31 deletions.
  1. +1 −0  .gitignore
  2. +0 −31 Gemfile.lock
1  .gitignore
View
@@ -6,3 +6,4 @@
ext/Makefile
lib/cbloomfilter.so
tmp
+Gemfile.lock
31 Gemfile.lock
View
@@ -1,31 +0,0 @@
-PATH
- remote: .
- specs:
- bloomfilter-rb (2.1.1)
- redis
-
-GEM
- remote: http://rubygems.org/
- specs:
- diff-lcs (1.1.2)
- rake (0.8.7)
- rake-compiler (0.8.0)
- rake
- redis (2.2.2)
- rspec (2.5.0)
- rspec-core (~> 2.5.0)
- rspec-expectations (~> 2.5.0)
- rspec-mocks (~> 2.5.0)
- rspec-core (2.5.1)
- rspec-expectations (2.5.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.5.0)
-
-PLATFORMS
- ruby
-
-DEPENDENCIES
- bloomfilter-rb!
- rake
- rake-compiler
- rspec
Something went wrong with that request. Please try again.