Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

1.0.3: VERSION.rb -> VERSION, cite original author

Kept getting already defined const nags when used with bundler so I
reverted VERSION.rb back to a simple text file and bumped the version.
  • Loading branch information...
commit c8ee70c1dc505a59557f47e42db5aabc9ea29f98 1 parent d851849
Mike Vincent shame authored

Showing 3 changed files with 4 additions and 6 deletions. Show diff stats Hide diff stats

  1. +1 0  VERSION
  2. +0 1  VERSION.rb
  3. +3 5 language_detector.gemspec
1  VERSION
... ... @@ -0,0 +1 @@
  1 +0.1.3
1  VERSION.rb
... ... @@ -1 +0,0 @@
1   -VERSION = '0.1.0'
8 language_detector.gemspec
... ... @@ -1,6 +1,5 @@
1 1 # -*- encoding: utf-8 -*-
2 2
3   -require './VERSION'
4 3
5 4 Gem::Specification.new do |s|
6 5 s.name = "language_detector"
@@ -8,12 +7,11 @@ Gem::Specification.new do |s|
8 7 s.description = "Ruby language detection library using n-gram model"
9 8 s.email = "ilya@igvita.com"
10 9 s.homepage = "http://github.com/igrigorik/language_detector"
11   - s.authors = ["Ilya Grigorik"]
  10 + s.authors = ["feedbackmine","Ilya Grigorik"]
12 11 s.rubyforge_project = "language_detector"
13   - s.version = VERSION
14   - s.files = Dir['lib/**/*'] + %w(README.rdoc)
  12 + s.version = File.read('VERSION') rescue '0.0.0'
  13 + s.files = Dir['lib/**/*'] + %w(README.rdoc VERSION)
15 14 s.required_rubygems_version = ">= 1.3.6"
16 15 s.require_paths = ["lib"]
17 16 s.rdoc_options = ["--charset=UTF-8"]
18 17 end
19   -

0 comments on commit c8ee70c

Please sign in to comment.
Something went wrong with that request. Please try again.